Ask Your Question
0

how to install necessary software for modular programming?

asked 2014-02-05 10:39:51 -0600

RavindraVT gravatar image

Presently I'm using Fedora 17. I wanted to know all necessary packages to be installed to write modular program. I'm learning device drivers right now. I tried to compile but giving errors.

edit retag flag offensive close merge delete

Comments

Fedora 17 has already been EOL and is not supported anymore. Please upgrade to a more recent and supported version.

NickTux gravatar imageNickTux ( 2014-02-05 11:31:02 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-02-05 11:04:04 -0600

davidva gravatar image

Upgrate to Fedora 20! https://fedoraproject.org/wiki/End_of_life https://lists.fedoraproject.org/pipermail/announce/2013-July/003177.html if you want install developer tools:

su

yum -y install kernel-headers kernel-devel hg git

yum -y groupinstall "Development Tools" "Legacy Software Development"

yum -y groupinstall "Development Libraries"

yum -y groupinstall "x-software-development"

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-02-05 10:39:51 -0600

Seen: 89 times

Last updated: Feb 05 '14