Ask Your Question
2

How to lock the screen with the keyboard in Fedora 20?

asked 2014-02-17 04:53:52 -0500

jringoot gravatar image

updated 2014-09-30 11:26:00 -0500

mether gravatar image

After updating to Fedora 20, locking the screen with the "CTRL+ALT+L" no longer works to lock the screen in the GNOME desktop. Previously the "CTRL+ALT+L" shortcut would bring down the screen shield and lock the screen. Now, when i press this key combo, nothing happens.

edit retag flag offensive close merge delete

Comments

I did some further tests: in gnome or gnome classic: doesn't work. In kde plasma and cinnamon, no problem: CTRL+ALT+L locks the screen.

jringoot gravatar imagejringoot ( 2014-02-17 10:54:11 -0500 )edit

On Fedora 19 screen lock did not work without gnome-screensaver running , see https://ask.fedoraproject.org/en/question/35171/no-screen-lock/ . If Super+L (or CTRL+ALT+L in other window managers) does not work for you - verify if gnome-screensaver is running with ps aux | grep screensaver. The issue needs to be officially clarified in Fedora docs - does it work on Fedora 20 out-of-the-box? Does one still needs gnome-screensaver installed, and configured manually?

marcindulak gravatar imagemarcindulak ( 2014-02-18 07:18:35 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
3

answered 2014-02-18 10:41:17 -0500

ryanlerch gravatar image

Fedora 20 includes GNOME 3.10, and in this newer version of GNOME, the default shortcut to lock the screen was changed to SUPER + L.

However, if you are more comfortable with the old shortcut (or some other shortcut), you can easily change it in GNOME control center's keyboard configuration screen:

image description

edit flag offensive delete link more

Comments

Thanks Ryan!

jringoot gravatar imagejringoot ( 2014-03-11 03:36:35 -0500 )edit
2

answered 2014-02-17 05:04:31 -0500

mihkel gravatar image

Use Super+L

edit flag offensive delete link more

Comments

I use the Mate desktop with Fedora - and it's still CTRL-ALT-L there. I use it all the time...

cobra gravatar imagecobra ( 2014-02-17 09:58:42 -0500 )edit

I guess you mean the "Windows-flag button" +L, doesn't work either. Thanks for looking in to it anyway

jringoot gravatar imagejringoot ( 2014-02-17 10:47:14 -0500 )edit

Well. That is strange.

http://i.imgur.com/w4dJpJN.png

Make sure that in gnome3 you have set Super+L (or whatever you want) to lock screen.

mihkel gravatar imagemihkel ( 2014-02-18 00:47:07 -0500 )edit
0

answered 2015-04-01 13:30:15 -0500

Just a quick note -- not every keyboard has a "super" key. My Model M does not.

edit flag offensive delete link more
0

answered 2014-06-19 01:36:38 -0500

Hi I am also on Gnome 3, and super+L is configured on keyboad but still its not working.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-02-17 04:53:52 -0500

Seen: 23,192 times

Last updated: Jun 19 '14