Ask Your Question
3

Where in Fedora 20 are the suspend and hibernate options?

asked 2014-03-13 02:32:38 -0500

robirobi gravatar image

updated 2014-03-26 15:57:19 -0500

mether gravatar image

I'm looking for an option to suspend or hibernate the machine but I can't find it. :)

edit retag flag offensive close merge delete

9 Answers

Sort by ยป oldest newest most voted
7

answered 2014-03-25 09:12:37 -0500

varesa gravatar image

You can suspend the computer by holding Alt while hovering over the power button from the top-right corner menu. It will turn into a "pause button".

edit flag offensive delete link more

Comments

It definitely doesn't on my Fedora 20 box.

robirobi gravatar imagerobirobi ( 2014-03-26 12:00:34 -0500 )edit
1

Works for me (F20) - open drop-down menu and only then press Alt.

mr.nejc gravatar imagemr.nejc ( 2014-04-10 15:59:05 -0500 )edit

On Fedora 21 on my Dell laptop works

climens gravatar imageclimens ( 2014-12-13 04:36:40 -0500 )edit

Thanks a lot, it works perfectly

ihsun gravatar imageihsun ( 2015-02-11 21:33:54 -0500 )edit

BTW, where is this feature explained?

climens gravatar imageclimens ( 2015-04-18 16:24:29 -0500 )edit
3

answered 2014-03-13 04:47:23 -0500

Sesivany gravatar image

If you mean GNOME environment, there are no such options. You suspend by closing the lid and to hibernate I think you have to use a command in terminal. You might find an extension to modify such a behavior: https://extensions.gnome.org/

edit flag offensive delete link more

Comments

Unfortunately my desktop has no lid. :)

robirobi gravatar imagerobirobi ( 2014-03-14 04:05:47 -0500 )edit

Thanks, the Hibernate Status Button works nicely!

robirobi gravatar imagerobirobi ( 2014-03-14 04:12:50 -0500 )edit
0

answered 2014-03-13 06:14:14 -0500

neurox gravatar image

If you're using the terminal, try pm-suspend and pm-hibernate. They're part of the pm-utils package.

edit flag offensive delete link more

Comments

Thanks! That's what I used so far but I was more looking for something in the UI I might have missed.

robirobi gravatar imagerobirobi ( 2014-03-14 04:20:14 -0500 )edit

As vigenere has said in 2015 on fedoraforum.org , these package is no longer available, replaced by something else, aka systemctl hibernate command @see http://forums.fedoraforum.org/showthr...

thbenda gravatar imagethbenda ( 2017-08-06 06:43:56 -0500 )edit
0

answered 2017-05-16 23:26:45 -0500

it works perfect with fedora 25 and dell workstation

edit flag offensive delete link more
0

answered 2016-03-17 14:26:56 -0500

systemctl suspend or systemctl suspend -i

you may assing pause or other key to use this shortcut

edit flag offensive delete link more
0

answered 2015-07-03 10:29:04 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

In gnome click at the battery status indicator in upper right corner and then hold 'alt'. You'll see, that shutdown button transforms to suspend button.

edit flag offensive delete link more
0

answered 2016-11-04 11:00:07 -0500

mikmik gravatar image

In Fedora 24 (and I believe it is from Fedora 22 up) the hibernate or hybrid sleep is not enabled by default. To enable it run this code as root:

#!/bin/bash
# Enable hibernation
# Using info from:
# https://psohny.wordpress.com/2015/08/13/fedora_hiber/

# Enable recovery in the /etc/default/grub
sed -i -e 's|^\(GRUB_DISABLE_RECOVERY="\)true"|\1false"|' /etc/default/grub

#Find the swapdevice
SWAPDEVICE=`grep -e '^[^#].*swap' /etc/fstab | head -n 1 | cut -d ' ' -f 1`
echo "Using SWAPDEVICE=${SWAPDEVICE} for hibernation"

#add "resume=swapdevice" to the GRUB_CMDLINE_LINUX=
sed -i -e "s|^\(GRUB_CMDLINE_LINUX=\".*\)\"|\1 resume=${SWAPDEVICE}\"|" /etc/default/grub

#Regenerate the grub config
/sbin/grub2-mkconfig -o /boot/grub2/grub.cfg

After regenerating the grub configuration, now you need to reboot your machine

reboot

Now after reboot it will be possible to hibernate or even hybrid-sleep

systemctl hibernate -i
systemctl hybrid-sleep -i
edit flag offensive delete link more
0

answered 2014-03-13 06:22:36 -0500

Fred2010 gravatar image

By accident, I discovered that the key combination "Superkey"-L does this. I wrote an uppercase L only for emphasis. I normally use an unshifted L.

Depending on your keyboard, the Superkey is either the Apple Command key or the Windows key.

edit flag offensive delete link more

Comments

On my system, that shortcut locks my screens and puts them in standby mode. The system itself keeps running (and my audio player keeps playing).

neurox gravatar imageneurox ( 2014-03-13 08:11:29 -0500 )edit
1

"Windows Key"+L neither does suspend nor does it hibernate my system, it just locks my box as described above.

robirobi gravatar imagerobirobi ( 2014-03-14 04:03:48 -0500 )edit
1

Yes, the above two comments are correct. Sorry for the mix-up.

I've tried the pm-hibernate and it works well.

What about using the Power settings in the "All Settings" app? It has a setting to "Suspend & Power Off" after an idle time.

Fred2010 gravatar imageFred2010 ( 2014-03-14 06:24:36 -0500 )edit

I don't have a "Suspend & Power Off" in the "All Settings" app. Where is it supposed to be?

robirobi gravatar imagerobirobi ( 2014-03-26 11:59:22 -0500 )edit
0

answered 2017-05-16 23:29:46 -0500

thank's works perfekt wih a old dell workstation + fedora 25 systemctl hibernate -i -->wake up with power button --> login again --> the apps are open I like fedora

edit flag offensive delete link more

Comments

Thanks, great tip to use from a java program, after a long time execution during the night :)

thbenda gravatar imagethbenda ( 2017-08-06 06:39:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-03-13 02:32:38 -0500

Seen: 36,913 times

Last updated: Mar 26 '14