Ask Your Question
0

Cannot serve directory /usr/share/phpMyAdmin

asked 2014-03-14 09:59:12 -0500

dinuka gravatar image

updated 2014-03-15 02:10:18 -0500

mether gravatar image

I have installed phpmyadmin for my desktop. I did some configaration for create a vhost in my home directory. After that phpmyadmin is not working. So i check /var/log/httpd/error_log. It is giving following error message.

[Fri Mar 14 20:16:23.563172 2014] [autoindex:error] [pid 4545] [client 127.0.0.1:54509] AH01276: Cannot serve directory /usr/share/phpMyAdmin/: No matching DirectoryIndex (index.html) found, and server-generated directory index forbidden by Options directive

I dont know how to fixed that. I checked /usr/share/phpMyAdmin directory. index.html is not there. But index.php is there. What should i do? Please help me.

edit retag flag offensive close merge delete

Comments

did you install it manually or from the repository ?

(try changing the DirectoryIndex to index.php)

Rabin gravatar imageRabin ( 2014-03-14 18:45:39 -0500 )edit

i installed it from repository. It was working fine.

dinuka gravatar imagedinuka ( 2014-03-14 20:52:50 -0500 )edit

@mether - please do not convert my comments into answers - i comment if i ask a question, i answer to provide a solution that i have verified

marcindulak gravatar imagemarcindulak ( 2014-03-15 05:08:10 -0500 )edit

Just an advice - don't use phpmyadmin ( http://stackoverflow.com/questions/3661911/does-phpmyadmin-pose-security-risk-on-production ). Have you tried to google the error? http://bit.ly/1iJzbMA

marcindulak gravatar imagemarcindulak ( 2014-03-15 05:08:29 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-08-11 01:02:43 -0500

ftrotter gravatar image

I had this problem because I had not installed php yet. I had already installed phpMyAdmin and in previous versions of the Fedora, this installed php too. I did a

yum install php

And everything started working.

HTH.

edit flag offensive delete link more

Comments

Fixing the DirectoryIndex to include index.php helped, but didn't actually run the php script. Installing php fixed that.

bwlcodez gravatar imagebwlcodez ( 2018-04-11 11:42:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-14 09:59:12 -0500

Seen: 7,555 times

Last updated: Aug 11 '14