Ask Your Question
0

C Programming in Fedora 20

asked 2014-04-13 23:43:35 -0500

SDas gravatar image

updated 2014-04-14 01:42:23 -0500

FranciscoD_ gravatar image

I am writing c programs in vi editor but all the texts are appeared in black colour. I had used previous version of fedora like fedora 17 and also wrote c programs there also using vi editor, but there all the texts didn't appeared in black colour, like the line #include<stdio.h> appeared there in different colour and there also some others. Rather than this every thing is ok my program is compiling and executing correctly. Why this is happening ? Any solution ?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
2

answered 2014-04-14 00:20:27 -0500

skytux gravatar image

I think you need to install vim-enhanced:

$ sudo yum install vim-enhanced

HTH,

Germán.

edit flag offensive delete link more

Comments

This not working after downloading 11 mb there occurs an error.

SDas gravatar imageSDas ( 2014-04-14 04:52:20 -0500 )edit

Maybe you also need to install vim-common?

skytux gravatar imageskytux ( 2014-04-14 13:05:57 -0500 )edit

@SDas : which error? You need vim to solve your problem.

kdg1955 gravatar imagekdg1955 ( 2014-04-15 09:21:32 -0500 )edit

This can also be done by downloading the binary package and then installing from there.

SDas gravatar imageSDas ( 2014-04-16 00:07:29 -0500 )edit
-1

answered 2014-04-15 07:03:53 -0500

nks gravatar image

you can use nano editor

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-04-13 23:43:35 -0500

Seen: 434 times

Last updated: Apr 15 '14