Ask Your Question
3

Fedora20, kmod-VirtualBox-kmod-VirtualBox-3.14.9-200.fc20.x86_64

asked 2014-07-03 01:37:00 -0500

infoget gravatar image

updated 2014-09-12 23:03:11 -0500

mether gravatar image

I have researched how I can install VirtualBox on my Fedora 20 without turning off Secure Boot and I found out that it's possible with the kmod-VirtualBox metapackage, but I can't find the version for my kernel (3.14.9-200) on RPMFusion. So do some alternative exist in this case? Such as using testing repositories etc.

I don't understand why, but the RPMFusion testing repository seems to be empty.

edit retag flag offensive close merge delete

6 Answers

Sort by ยป oldest newest most voted
2

answered 2014-07-03 02:11:55 -0500

NickTux gravatar image

updated 2014-07-03 02:16:21 -0500

Yes, RPM Fusion does not have the oracle virtualbox modules yet. You have to wait until they build the package.

Do you know how I run oracle virtualbox on my Fedora 20 , with no need of kmod-virtualbox--- modules ?

I have added the Official Oracle virtualbox repository (this is for the latest VirtualBox version)

[virtualbox]
name=Fedora $releasever - $basearch - VirtualBox
baseurl=http://download.virtualbox.org/virtualbox/rpm/fedora/$releasever/$basearch
enabled=1
gpgcheck=1
gpgkey=http://download.virtualbox.org/virtualbox/debian/oracle_vbox.asc

Then install virtualbox like this

sudo yum install VirtualBox-4.3

then install dkms and enable dkms.service . The dkms helps to build the modules that needed for the kernel.

sudo yum install dkms ; sudo systemctl enable dkms.service

Reboot your system and see if it works. If not, see the errors, maybe it needs some development pacakges, I'm not sure which of these, because I have the whole "Development Tools" installed on my system.

Right now I have Oracle Virtualbox 4.3.12 with 3.14.9-200.fc20.x86_64 and it is working without problems.

edit flag offensive delete link more

Comments

1

Thank you for your time! But here is the problem, that when you want use dkms, then you have to turn off secure boot, but it's not nice solution for me. Correct me If I am wrong. (I don't want turn off secure boot, bcs my Fedora20 was installed with this option so what if my system doesn't boot anymore...)

infoget gravatar imageinfoget ( 2014-07-03 03:41:14 -0500 )edit

Thanks, VirtualBox-4.3 works for me.

chlab gravatar imagechlab ( 2014-07-03 03:48:18 -0500 )edit

I don't think that dkms and secure boot have a relationship. I'm not sure though, because I don't have secure boot. You can try and see. If you cannot boot, disable secure boot only once and remove/disable dkms service

NickTux gravatar imageNickTux ( 2014-07-03 04:02:21 -0500 )edit
1

Yep, it has, it's not possible load modules: modprobe vboxdrv : modprobe: ERROR: could not insert 'vboxdrv': Required key not available

infoget gravatar imageinfoget ( 2014-07-03 04:47:25 -0500 )edit

I don't know if this is a virtualbox or dkms problem, really. I've found this bug which indicates that probably is Fedora's problem ? Either way, I cannot suggest another solution. If you don't want to disable secure boot, then wait for RPM Fusion to build that kernel module, or wait for another friend here to suggest another solution. Thanks.

NickTux gravatar imageNickTux ( 2014-07-03 08:15:11 -0500 )edit
1

answered 2014-07-16 13:18:16 -0500

hedayat gravatar image

updated 2014-07-17 06:21:04 -0500

I wonder if RPMFusion kernel modules are signed with Fedora signing key, but if it is true, you have 3 options:

  1. Wait for RPMFusion to build new kmod- packages. You can't use akmod for a system with Secure boot enabled because, just like dkms, the modules won't be signed and kernel will refuse to load them.
  2. Disable Secure boot. AFAIK, Fedora should boot without any problems if you disable secure boot after installation (Even if it has, you can enable it again and it must work).
  3. (Hard way!) Create your own key pairs, enroll it into UEFI, and sign everything (shim, grub2, kernel and all modules) with your own keys! Update: If you can add your own key to UEFI (you might be able to do it using UEFI's own setup screens or using mokutils package in Fedora) in addition to existing keys, then it is enough to sign only the module you compile yourself. As far as I see, Fedora kernel should consider all keys available in UEFI in addition to its own key, and loads kernel modules if they are signed with any of them. I still wonder if RPMFusion kmod's work on Fedora, and how.
edit flag offensive delete link more

Comments

RPMFusion kernel modules are signed with RPMFusion gpg not Fedora key

sergiomb gravatar imagesergiomb ( 2014-07-16 16:49:25 -0500 )edit

I've searched a bit, and found nothing about loading modules signed with third party keys in Fedora official kernels when secure boot is in effect. If that's the case, so it should be possible for us to compile kernel modules and sign them with our own key and register this key with Fedora kernel so that we can load them. Do you know how this can be achieved (in other words, what did RPMFusion folks do so that their keys are accepted by Fedora kernel)?

hedayat gravatar imagehedayat ( 2014-07-16 20:07:30 -0500 )edit

Hi, this is a good question for rpmfusion-developers@lists.rpmfusion.org , I don't know sorry

sergiomb gravatar imagesergiomb ( 2014-07-17 10:56:40 -0500 )edit

Do you know of a step-by-step guide to implement option 3?

cgonz31 gravatar imagecgonz31 ( 2014-09-24 23:51:50 -0500 )edit

Which one? The updated method (just enrolling your own keys into UEFI and signing your own modules) or the original one (sining everything with your own keys)? The former should be much easier, and all you need should be mokutils for enrolling the key into UEFI, and pesign for signing modules.

hedayat gravatar imagehedayat ( 2014-09-25 06:56:09 -0500 )edit
0

answered 2014-10-02 09:03:22 -0500

smittix gravatar image

With the problem regarding signing this may be because of secure boot. Does you system use Secureboot? if so try switching secureboot off and try and run it.

Thanks

Smittix

edit flag offensive delete link more
0

answered 2014-07-15 07:13:10 -0500

sergiomb gravatar image

updated 2014-07-16 16:58:38 -0500

rpmfusion infrastructure had problems , and kmods was not built , but now rpmfusion get back on .

Please don't say to switch to oracle rpms , because rpmfusion packages are much better in all aspects .

kernel-3.14.9-200.fc20.x86_64 was exactly the kmod that was delayed , by infrastructure problems .

Normally we don't have any delay

edit flag offensive delete link more
0

answered 2014-07-05 20:50:19 -0500

LinuxBlue gravatar image

problem is kmod v akmod... use akmod and not kmod as kmod doesn't update kernel properly... I have same problem with mine and can find kernek drv on boot...but dont thk its kmod problem. The problem seems to be the secure boot but I installed from oracle and not from yum, so it setup kmod and not akmod...so have to remove kmod and install akmod..ok!

edit flag offensive delete link more

Comments

hi if you use Fedora stable version ie F20 or F19 , you should install kmod-VirtualBox-4.3.16-1.fc20.1.x86_64 a meta-package which sole purpose is to require the VirtualBox kernel module(s) for the newest kernel. to make sure you get it together with a new kernel.

sergiomb gravatar imagesergiomb ( 2014-09-25 09:40:26 -0500 )edit
0

answered 2014-10-05 11:47:08 -0500

Hi, i have a pre-installed win 8, Dell inspiron 3421, secure boot on I had the same problem and based on some of the answer's above, did the following

1) Reboot 2) Press F12 before grub loads 3) go to Change Boot Mode Setting 4) once there you'll see 2 options, select UEFI Boot Mode, Secure Boot Off.

and that's it

it worked 4 me, i switched on and off to see if that was the problem , and now VirtualBox loads with no error hope this help.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2014-07-03 01:37:00 -0500

Seen: 3,398 times

Last updated: Oct 05 '14