How can I run a script at startup in a chroot Fedora 18 on Android?

asked 2014-08-15 16:29:26 -0500

monkmandolins gravatar image

updated 2015-03-28 10:30:51 -0500

Hi I was successful in setting up Logitech Media Server in a chroot Fedora 18 following this guide: http://www.jamesarbrown.com/?p=186

And first installing: yum install gcc make automake patch zlib-devel gcc-c++ nasm git

I used linux deploy to make a fedora 18 chroot. I have the LMS working now, which is great, but I can’t figure out how to add the startup script to get it to load automatically.

This is what I need to run: /opt/Perl5.14/bin/perl -I /opt/slimserver-vendor/CPAN/build/arch/5.14 /opt/slimserver/slimserver.pl

Which is the last line of this guide: http://www.jamesarbrown.com/?p=186

Do you have any idea how I can do this? I keep getting this message:

“Running in chroot, ignoring request.”

Thank you so much. For what it's worth, I am using this in conjunction with a Raspberry Pi in my car for car audio with no modifications. I just found out that the Pi can emit a radio signal without ANY physical attachments (although an antenna helps). So the plan is server and player app on the phone, squeezelite on the raspberry pi sending to the car radio via radio frequency.

edit retag flag offensive close merge delete

Comments

Welcome to Ask Fedora. Alas, this site offers help for all supported versions of Fedora, but Fedora 18 is no longer supported. It's possible that somebody here might be able to help you, but you'd probably be better off if you upgraded to either Fedora 19 or 20, the two versions that are currently supported. In any event, good luck and I hope you find the info that you need.

sideburns gravatar imagesideburns ( 2014-08-15 18:17:32 -0500 )edit