Ask Your Question
0

Pre-installed Windows 8 failed to start after installing Fedora 20 in Legacy Support

asked 2014-09-15 18:33:04 -0500

Quantum Helix gravatar image

updated 2014-09-28 19:48:31 -0500

Hi everyone!

Brief:

I ended up installing Fedora 20 in Legacy on the same HD as Windows 8. I wound up being able to launch Fedora, but not Windows 8.

Detailed:

I encountered a problem with trying to boot my Pre-Installed Windows 8 (64 bit) after installing Fedora 20 (64 bit Plasma). My default boot setting was using UEFI, but I had to use Legacy Support boot to install Fedora 20, using LiveUSB, because the USB wasn't displaying in UEFI boot option list(I didn't knew UEFI needs FAT32 format). I did so on the separate partion. After the installation completed, I restarted in Legacy Support to select Windows 8 boot, and it displayed the message:

Windows 8 failed to start. A recent hardware or software change might be the cause...  Requires Installation disk to repair it...

Using Fedora, I checked that Windows 8 files were still there, and I could access them. I tried rebooting in UEFI, and it displayed:

Default Boot Device Missing... requires Recovery Media.

I mounted Windows 8 iso on USB, formatted it as FAT32 (because UEFI needs this format) and made it to boot the installation in UEFI mode. Instead of installing Windows 8, I chose Repair my Computer, but no option in that light blue screen helped me to repair Windows 8. This USB cannot be used as Recovery either, but I thought that USB can act as Recovery Media as well, since it has all the Windows files necessary. Also, since Windows came pre-installed, I don't know the product key, so I cant just re-install Windows. (Maybe there is a command prompt command that lets me see it, but I don't know yet)

So, here are my questions: How do I make the Windows to boot again? Reformat the disk, and if so, how? Complete clean install of Windows and Fedora from scratch? 3rd party programs? How to make Recovery USB to work? Is LiveUSB of Windows 8 installation can be used as "Recovery Media"? How to make a Recovery from the ISO file and not boot installation? Should I choose UEFI or Legacy Support for dual boot and why??

Thank you!

Updates:

*# 1. I mounted Fedora with LiveUSB using FAT32 format and installed Fedora in UEFI using LVM partioning and deleted the Legacy Fedora partion.

*# 2. For now, I have found This: http://forums.fedoraforum.org/showthread.php?t=292311

I am searching the answer there for now.

*# 3. The last post in Update *# 2 forum link might actually be the answer, I'll try it out and if it helps, that is the answer..

*# 4. Solved!!!

edit retag flag offensive close merge delete

Comments

I also didn't turn the security boot at any time, since I thought that it might block something from happening...since, security.... you know...

Quantum Helix gravatar imageQuantum Helix ( 2014-09-17 23:13:15 -0500 )edit

Please send me a link to a similar problem on the forum, if you think it's answer might help me.

Quantum Helix gravatar imageQuantum Helix ( 2014-09-17 23:16:39 -0500 )edit

By this time, I already have tried out asking Google of all the questions I could think about to my problem and I still can't find the correct answer.... but at least I have learned some info...

Quantum Helix gravatar imageQuantum Helix ( 2014-09-17 23:21:44 -0500 )edit

Why did you switch to Legacy Support at all? You should be able to install Fedora in UEFI mode too, and it should play much better with your existing Windows installation.

Also, I'm not sure if I understood correctly: you have 3 hard disks? and you have installed Fedora on a spare one? Have you touched your partitions in the main hard disk during the installation process? What kind of partitioning you use in Fedora installer? Automatic or Custom? With which settings?

hedayat gravatar imagehedayat ( 2014-09-18 05:45:04 -0500 )edit

I tried to switch to Legacy because it couldn't boot the Fedora in my USB in UEFI boot. I have a C: hard disk with Windows in it, but I decided not to risk it and found that I have a small 25 GB hard disk, with some files that I think Windows won't use, so I created a 10 GB partion on it during the Fedora installation and installed Fedora there. (Although, before I installed Fedora on D:, I did try and make a partion on C:, but in the end, I didn't to use it. (I think, if I had to choose the partion my self, then I might used Custom) About "With which settings?", I don't remembered about that.

Quantum Helix gravatar imageQuantum Helix ( 2014-09-18 18:17:54 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2014-09-27 12:41:57 -0500

Quantum Helix gravatar image

updated 2014-09-27 13:11:25 -0500

Solved!

All that got me to make the dual boot to work was to mount Fedora with LiveUSB in FAT32 format to make it boot in UEFI, and Install it. During the Fedora installation, I deleted the Legacy Fedora from my HDD and that solved the problem. If the Windows boot option does not appear for you, using Fedora download the rEFInd .RPM, and install it from the command line to a USB, as suggested, and boot it. (Source: FORUM; rEFI Boot Manager. Look at the last post in the forum, it might help!)

edit flag offensive delete link more

Comments

That's a huge post to read through, could you please summarize here?

randomuser gravatar imagerandomuser ( 2014-09-27 12:45:37 -0500 )edit

@randomuser Is it ok If I shrink the question down to the important info (Removing the sudo blkid - output command and other not important history)?

Quantum Helix gravatar imageQuantum Helix ( 2014-09-27 12:53:57 -0500 )edit

@Quantum Helix go for it, I think that would be very helpful to future readers!

randomuser gravatar imagerandomuser ( 2014-09-27 20:56:54 -0500 )edit

I think it would be easy enough to add an entry for Windows to grub menu (like what @sea said) rather than using rEFInd. Also, if Fedora didn't add an entry for Windows for you, It'd be nice if you can provide the output of these commands for me (either opening a bug report for it or post it somewhere for me) (I'm the maintainer of os-prober package, so I'd like to see if it cannot find your Windows boot entry):

os-prober
grub2-mkconfig
hedayat gravatar imagehedayat ( 2014-09-29 03:08:32 -0500 )edit

I find refind very confusing to begin with. Not much support, no good aesthetics (although I really don't mind), and confusion. I tried it with Fedora the first time and I messed up some thing really bad.

abadrinath gravatar imageabadrinath ( 2014-09-29 23:51:23 -0500 )edit
0

answered 2014-09-25 03:55:58 -0500

sea gravatar image

updated 2014-09-25 14:10:24 -0500

You could try to make a a new grub entry in /etc/grub.d/40_custom. Todo so, open a termial and type the following (provide root's password after 'su'):

su
gedit /etc/grub.d/40_custom

And copy paste (appending) the following:

menuentry "Windows 8" --class windows {
    insmod part_gpt
    insmod fat
    insmod search_fs_uuid
    insmod chain
    search --fs-uuid --no-floppy --set=root 885C-7318
    chainloader (${root})/efi/Microsoft/Boot/bootmgfw.efi
}

Make sure the file has execution flag and rebuild grub as root with:

grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

Hope this helps

edit flag offensive delete link more

Comments

@sea Why would I need to do that? How will it help? I'm still learning what GRUB is...

Quantum Helix gravatar imageQuantum Helix ( 2014-09-25 09:13:49 -0500 )edit

This will set another entry within the grub menu.

Myself (and others) have the same (very simliar at least) issue and this is how i boot to windows.

sea gravatar imagesea ( 2014-09-25 09:29:10 -0500 )edit

@sea I think the Second command I type in to terminal, but I don't get the first command. How do I type it? and where? into terminal? without spaces between the lines? I tried putting "menuentry "Windows 8" --class windows" it in terminal, command not found... BTW, how do I login as root in a "Window" terminal, not the "Ctrl+Alt+F2" terminal? .....Ok writing grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg gave me the output and one of them is Windows 8 (loader) on /dev/sda5

Quantum Helix gravatar imageQuantum Helix ( 2014-09-25 13:13:42 -0500 )edit

I've edited the answer, please change 'gedit' to a texteditor of your choice, if it doesnt work that is.

sea gravatar imagesea ( 2014-09-25 14:09:24 -0500 )edit

@sea Nor "gedit" nor "KWrite" could make a new grub entry. What are other text editors I could use?

Quantum Helix gravatar imageQuantum Helix ( 2014-09-25 19:45:37 -0500 )edit
0

answered 2014-12-26 14:44:26 -0500

rajju gravatar image

generally you can check this case from bios ..might be issue with the sata mode

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-15 18:33:04 -0500

Seen: 6,219 times

Last updated: Dec 26 '14