Ask Your Question
0

F20: Dropbox at startup

asked 2014-10-08 12:14:28 -0500

buggyfreak gravatar image

updated 2014-10-08 19:24:12 -0500

mether gravatar image

Hello everyone,

I'm quite new to fedora. i've installed dropbox but i've noticed it doesn't run at startup. so i searched and found a script at this site : http://www.dropboxwiki.com/tips-and-tricks/install-dropbox-in-an-entirely-text-based-linux-environment#feboraredhat

I have put this in my init.d but it doesnt seem to startup and i don't see the dropbox logo in my messages bar.

The perfect thing would be something to call "dropbox start" at startup of the system.

Hope somebody can help. Greetings a Belgian fedora user.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-10-08 22:56:18 -0500

sideburns gravatar image

Fedora uses systemd, which doesn't use init.d. You need to create the shell script /etc/rc.d/rc.local either putting the commands in directly, or invoking another script containing the commands and make it executable. Then, just to be sure, run this command as root:

systemctl enable rc-local.service

This will make sure that it gets run at boot.

edit flag offensive delete link more
0

answered 2014-10-08 14:10:16 -0500

heshamwhite gravatar image

if you use Kde you can use Autostart and add any application you want to start when you log in." Press Alt+F2 and type 'Autostart' without the quotes"

If you use gnome then "Press Alt+F2 and type 'gnome-session-properties' without the quotes"

if you want to create it manually:

You should put in a Desktop Entry file inside of ~/.config/autostart (for a user) or /etc/xdg/autostart (for the whole system). In the file you set the script to run (see the option Exec). For more information, check the Desktop Application Autostart Specification.

For example, you can put a file with the following content:

[Desktop Entry] Name=MyScript GenericName=A descriptive name Comment=Some description about your script Exec=/path/to/my/script.sh Terminal=false Type=Application X-GNOME-Autostart-enabled=true

PS: The credit of the manual way goes to gpoo. I never tried it myself

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-10-08 12:14:28 -0500

Seen: 1,257 times

Last updated: Oct 08 '14