Ask Your Question
2

GNOME Fails to Start After FedUp to Fedora 21 Beta

asked 2014-11-06 11:30:47 -0500

cgonz31 gravatar image

updated 2014-11-06 16:22:10 -0500

I used the network upgrade with the recommended command:

fedup --network 21 --product workstation --instrepo https://dl.fedoraproject.org/pub/alt/stage/21_TC1/Server/x86_64/os/

Common F21 Bugs

Upgrade finishes fine. I rebooted and after the Fedora balloon fills up, I get the black screen of death. It's stuck at:

[  OK  ] Started GNOME Display Manager.

The system is live. I can use the tty console. I went to runlevel 3 and performed the following operations:

Rebuilt the RPM database, distro-synced, and updated.

Disabled Testing-Updates repo and switched the RPMFusion repos from Rawhide to F21 (this was an F20 system before the upgrade but after the upgrade the Rawhide repos were enabled for some reason).

Reinstalled gdm.

Reinstalled akmod-nvidia.

I rebooted after every step. No luck. Still stuck at the message. Any suggestions on how to fix this? Thanks.

Hardware:

Gigabyte Z97-UD3H

Intel Core i7-4790k

NVIDIA GTX 750

Update:

With verbose booting I can see the following messages where it's stuck:

[OK] Stated GNOME Display Manager.
[ 7.239722] e1000e: em1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[ 7.240079] IPv6: ADDRCONF(NETDEV_CHANGE): em1: link becomes ready
[37.808605] Adjusting tsc more than 11% (2359261 vs 2327840)

If I boot in verbose with the ethernet cable unplugged, it just gets stuck at the the GNOME Display Manager line.

edit retag flag offensive close merge delete

Comments

1

what's your hardware ? GPU ? did you try "modprobe nvidia"

baoboa gravatar imagebaoboa ( 2014-11-06 14:59:23 -0500 )edit

If you log into a tty ('Ctrl'+'Alt'+'F2'), what is the output of sudo systemctl status gdm?

wilf gravatar imagewilf ( 2014-11-06 15:07:06 -0500 )edit

You should try re-enabling the updates-testing repo. Many updates are there, because of the prerelease freeze.

randomuser gravatar imagerandomuser ( 2014-11-06 15:14:10 -0500 )edit

Hardware list was added to the question. modprobe nvidia does not find the module.gdm service is active if I just jump to the console without switching to init 3. Reactivating the Updates-Testing repo yielded several updates. They are installing right now...

cgonz31 gravatar imagecgonz31 ( 2014-11-06 15:24:22 -0500 )edit

The updates did not help but I did notice that if I turn on the verbose booting I get the messages about the ethernet connection (see updated question).

cgonz31 gravatar imagecgonz31 ( 2014-11-06 15:38:24 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted
2

answered 2014-11-06 16:06:24 -0500

baoboa gravatar image

updated 2014-11-06 16:18:13 -0500

ok , if modprobe nvidia fail it means you don't have the nividia module for your kernel

did you get the nividia from rpmfusion ?

yum list installed "*nvidia*"

did rpmfusion repos are active ?

yum repolist

i'm using at now

  1. rpmfusion-free-rawhide/x86_64 RPM Fusion for Fedora Rawhide - Free 473
  2. rpmfusion-nonfree-rawhide/x86_64 RPM Fusion for Fedora Rawhide - Nonfree 176

personnaly i'm using negativo17 repo for fedora21

yum-config-manager --add-repo=http://negativo17.org/repos/fedora-nvidia.repo

yum remove "*nvidia*" && yum install nvidia-driver dkms-nvidia nvidia-driver-libs.i686

edit flag offensive delete link more

Comments

Yes I got them from RPMFusion. Currently installed are:

akmod-nvidia-343.22-3.fc21.x86_64
xorg-x11-drv-nvidia-343.22-2.fc21.x86_64

rpm -qa|grep nvidia shows these extra packages:

xorg-x11-drv-nvidia-libs-343.22-2.fc21.x86_64
xorg-x11-drv-nvidia-cuda-343.22-2.fc21.x86_64
xorg-x11-drv-nvidia-kmodsrc-343.22-2.fc21.x86_64
cgonz31 gravatar imagecgonz31 ( 2014-11-06 16:28:07 -0500 )edit

what's happen if you use "akmodsbuild" ?

baoboa gravatar imagebaoboa ( 2014-11-06 16:49:22 -0500 )edit

I can now say that the NVIDIA drivers are the culprit. I switched to the Intel Integrated Graphics and it booted just fine. I'm about to install the NVIDIA drivers from scratch.

cgonz31 gravatar imagecgonz31 ( 2014-11-06 16:59:03 -0500 )edit
1

I reinstalled the akmod packages. Did not work. Then I tried with the kmod packages. Did not work. Then I tried the drivers from negativo17. It worked perfectly. Thank you so much for your help.

cgonz31 gravatar imagecgonz31 ( 2014-11-06 17:38:46 -0500 )edit
0

answered 2014-11-07 01:14:22 -0500

Gaurav Dighe gravatar image

You need to remove akmod-nvidia kmod-nvidia and xorg-x11-drv-nvidia* and then reboot. Then install akmod-nvidia and kernel-devel and then reboot. Then if it doesnt start, then go to init-terminal and give command sudo akmods --force and then reboot. It should work

edit flag offensive delete link more
0

answered 2016-01-21 11:44:57 -0500

Songi gravatar image

if something goes wrong or I find a better permanent solution I will definitely update here. Songs hindi download

edit flag offensive delete link more
0

answered 2019-01-29 07:45:21 -0500

Hi, Hope you are doing good. I have read carefully read your post. Thank you for sharing with us. Satta Matka

edit flag offensive delete link more
0

answered 2015-01-26 16:02:43 -0500

Hello,

I was searching for a similar problem on the internet when I found this article, just one more thing to add as it worked for me, I switched to console using control alt F2 keys and then typed startx and the issue was resolved, its weired but it worked for me, what I don't know for the moment is whether the issue will reoccur once I reboot the system, if something goes wrong or I find a better permanent solution I will definitely update here.

Thanks & Regards, Matka & Satta Matka

edit flag offensive delete link more

Comments

could you link to the article?

wilf gravatar imagewilf ( 2015-02-20 10:31:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-11-06 11:30:47 -0500

Seen: 15,047 times

Last updated: Jan 21 '16