Ask Your Question
0

Cannot boot latest kernel update after installing on new system

asked 2014-12-01 09:00:23 -0500

jflory7 gravatar image

updated 2014-12-03 08:39:49 -0500

mether gravatar image

I recently built my own computer, and I was excited to finally get to the installation of the operating system. Of course, I chose Fedora to use as my primary operating system, and I was able to successfully install the system as I wished without running into any major issues.

I started with an updated ISO from October 27th that I downloaded from the link in the IRC channel topic (here). One of the first things I ended up doing was updating the system with sudo yum update, which there were about 80 different packages that needed updating. The kernel version that was included with my ISO was a 3.16 variant, and the update installed the latest 3.17 kernel update available for Fedora 20. I successfully updated and rebooted my machine.

Upon reaching the kernel selection screen, it automatically booted into the latest kernel, and it was here that I first noticed the issue. Immediately after the kernel option was selected, it very quickly popped up with some sort of error message (I think something about TCI check failing?) and then proceeded to a blank, black screen. My only option at this point was to power off and power back on.

Just in case it may have been a random error, I did try rebooting a few times and kept getting the same results. I then tried going back to the original kernel version installed with my system, and it immediately prompted me for my hard drive decryption phrase. After entering the phrase, I was successfully able to log back into my system.

Is there something added in the latest kernel that might have an incompatibility with my system? Or is there a place where I can check the full system log? I'm not an expert with Linux, but I do know how to navigate the system via command line, so if you need more information, please just ask for it and tell me where to find it! Thanks.

Edit #1

Additionally, I have also tried booting into runlevel 3 or multi-user mode in systemd, and even that ended up with the same result as before. I manually edited the kernel boot parameters and added systemd.unit=multi-user.target, and even with that parameter, there was no change in my results, limiting my ability to further diagnose the issue.

edit retag flag offensive close merge delete

Comments

There's always the possibility that something in a new kernel won't work right for you. That's why Fedora (and most other distros) keeps several backup kernels. For the moment, just use the old kernel, and hope that somebody works out what's going on.

sideburns gravatar imagesideburns ( 2014-12-02 16:19:26 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-12-02 19:12:53 -0500

jflory7 gravatar image

As it turns out, it seems the underlying issue was not having the right proprietary drivers installed for my nVidia graphics card. I was under the presumption that I had to use nVidia's driver installer, but installing the right packages from RPMFusion and disabling Nouveau worked perfectly. Since installing the necessary drivers, my system is running signifcantly smoother, and it also eliminated this annoying magenta line that was on the far left end of my monitor.

I followed a guide from if-not-true-then-false.com , which can be found here. I installed the drivers and then re-enabled Plymouth as per the instructions in the guide. This fixed 100% of my issues.

edit flag offensive delete link more
0

answered 2014-12-01 11:08:00 -0500

swilson gravatar image

Try booting to runlevel 3 and reviewing dmesg output.

edit flag offensive delete link more

Comments

How can I do this from the kernel selection screen? I tried editing the kernel boot command and added in target=multi-user.target with information I found from the Fedora Wiki, but it wasn't clear how to do this if you weren't already booted.

jflory7 gravatar imagejflory7 ( 2014-12-01 15:40:07 -0500 )edit

Figured out how to do it. systemd.unit=multi-user.target. However, adding that as a boot parameter had no effect on the black screen. Immediately upon loading the kernel with the changes, it went to the exact same black screen as before. Any thoughts?

jflory7 gravatar imagejflory7 ( 2014-12-01 20:46:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-12-01 09:00:23 -0500

Seen: 1,103 times

Last updated: Dec 03 '14