Ask Your Question
0

Nvidia driver issue with f21.

asked 2014-12-10 09:51:52 -0500

Gaurav Dighe gravatar image

updated 2014-12-10 15:17:00 -0500

mether gravatar image

I have upgraded my fedora20 to fedora21.

I am facing issue while installing Nvidia driver.

While in F20..I use to install rpmfusion and follow it up with akmod-nvidia and kernel-devel.

I tried the same in f21, but every time it gives me "OOPS SOMETHING WENT WRONG> PLEASE LOGUT".

I even tried installing akmod-nvidia-304* but again I am getting the same issue.

Kindly assist.

edit retag flag offensive close merge delete

Comments

I've got the same problem with the same versions of fedora and nvidia driver (my card is GeForce 9600M GT). In Xorg.1.log I have nothing special - no errors or something that. I'm still googling and searching...

qherx gravatar imageqherx ( 2014-12-11 01:53:38 -0500 )edit

I've got the same with GeForce 8500 GT, I've made a screenshot: https://fotki.yandex.ru/next/users/xy/album/367065/view/1058211

ssr gravatar imagessr ( 2014-12-14 18:30:20 -0500 )edit

After removing nvidia drivers nouveau drivers are not restored and Fedora 21 loads with software rendering. I am now stuck with problem on how to turn nouveau back on.

ssr gravatar imagessr ( 2014-12-16 14:45:49 -0500 )edit
ssr gravatar imagessr ( 2014-12-16 18:13:00 -0500 )edit

Similar problem. I did a clean install then use akmod + rpmfusion. The machine fails to boot after the installation. I tried several times and it never worked.

Koala Yeung gravatar imageKoala Yeung ( 2014-12-23 22:30:36 -0500 )edit

6 Answers

Sort by ยป oldest newest most voted
0

answered 2014-12-18 15:48:57 -0500

Marek gravatar image

You can use repository http://negativo17.org/nvidia-driver/ instead of RPMFusion repository where it seems 343 driver is broken and they don't provide legacy 340 driver which are now required for old Nvidia cards as 343 doesn't support them.

edit flag offensive delete link more

Comments

negativo17 drivers (340xx) work for me on my GT 220 versus rpmfusion drivers. Thanks.

heberv gravatar imageheberv ( 2015-03-16 13:32:49 -0500 )edit
0

answered 2014-12-18 05:07:03 -0500

ssr gravatar image

Try to download and install drivers from NVidia website! Here is the page http://www.nvidia.com/Download/index.aspx -- you can select your card, download .run file from there and run it with "sudo sh" command. You'll have to stop the X server by command "sudo init 3".

But there may be troubles! I have mixed results on 2 machines, one GeForce 8500 GT, other GeForce GT 730 and 2 monitors. There may be conflicts with nouveau and akmod, problems with restoring nouveau. But some configurations work. Hope people here advice more. We'll may be considering raising bug at nvidia forums, as todo o mundo suggests.

edit flag offensive delete link more
0

answered 2015-03-15 21:24:44 -0500

heberv gravatar image

Same Problem with a GT 220 I try 340xx with the same results ( Upps, blah, blah, blah ). I install the latest driver from fedora 20 with yum --releasever=20 install akmod-nvidia xorg-x11-drv-nvidia-libs.i686 --nogp.

edit flag offensive delete link more
0

answered 2015-01-13 20:42:16 -0500

Make sure the module is loaded "modprobe nvidia" before starting GDM or Gnome-3. This was my problem.

edit flag offensive delete link more

Comments

How can you do that?

InjenieroBarsa gravatar imageInjenieroBarsa ( 2015-01-18 13:40:59 -0500 )edit
0

answered 2014-12-16 20:51:33 -0500

juliano gravatar image

here nvidia akmod for fedora 21 dont work latest nvidia stable and beta from nvidia website dont work too

report this bug for nvidia developers https://forums.geforce.com/default/board/33/geforce-drivers/

edit flag offensive delete link more
0

answered 2014-12-10 14:17:39 -0500

sergiomb gravatar image

updated 2015-01-19 12:53:58 -0500

Hi , please report this on rpmfusion mailing lists or rpmfusion bugzilla , I kown that we don't have nvidia-340 maintainer or something like that

thanks

UPDATE : nvidia-340 have been published on rpmfusion, so you can try it !

edit flag offensive delete link more

Comments

+sergiomb how to report this on rpmfusion mailinglist.

Gaurav Dighe gravatar imageGaurav Dighe ( 2014-12-10 20:53:24 -0500 )edit

hi , I think it already reported here https://bugzilla.rpmfusion.org/show_bug.cgi?id=3416 .

sergiomb gravatar imagesergiomb ( 2014-12-12 20:05:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

5 followers

Stats

Asked: 2014-12-10 09:51:52 -0500

Seen: 9,122 times

Last updated: Mar 15 '15