Ask Your Question
2

problem using nvidia proprietary driver on fedora 21

asked 2014-12-12 05:23:36 -0500

eyal6699 gravatar image

updated 2014-12-12 20:23:10 -0500

mether gravatar image

Hi, I upgraded to fedora 21 yesterday. After I rebooted, instead of the usual login screen appeared a message that say something went wrong with a button to log out. When I clicked the button all the screen went black, so I deleted the proprietary driver and for now I am running nouveau. Do you have an advice how to get the computer work back on the proprietary driver?

edit retag flag offensive close merge delete

10 Answers

Sort by ยป oldest newest most voted
0

answered 2014-12-30 05:12:29 -0500

hedayat gravatar image

First, try installing 'akmod-nvidia-304xx' and see if it works. If not, as Gaurav Dighe said, it might be because the driver versions in rpmfusion F21 repository doesn't support your card. I got around this by installing latest akmod-nvidia and dependencies from RPMFusion F20 repository; and it works fine.

edit flag offensive delete link more
0

answered 2014-12-12 11:32:55 -0500

Gaurav Dighe gravatar image

Which NVIDIA Draphic Card do you have.

If you have installed Rpmfsuion on f21, then they will provide you with 2 versions of akmod-nvidia.

  • akmod-nvidia This will give you nvidia-343
  • akmod-nvidia-304 This will give you nvidia-304

My grpahic card didnt support Nvidia-343, the last greatest release supported is 340(for my card).

Therefore, check and then you are free to go.

You can also download the driver from Nvidia website and install it. Its also pretty easy. I did the same.

Boot into fedora 21 with the run level set to 3(sudo init 3)

sudo mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img

sudo dracut --omit-drivers nouveau /boot/initramfs-$(uname -r).img $(uname -r)

Reboot and make sure to boot into runlevel 3

nouveau is now disabled

Run the NVidia installer

Reboot and load normally

CAUTION- If you decide to download the driver from Nvidia and then install it, then you need to repeat these steps for every kernel update or else you wont get the GDM working. Its simple though.

edit flag offensive delete link more

Comments

I encountered a similar issue, but instead of using nvidia drivers directly, I used F20 nvidia akmods which provide version 331. It works fine on F21.

hedayat gravatar imagehedayat ( 2014-12-30 05:10:22 -0500 )edit
0

answered 2014-12-12 11:45:51 -0500

DenTer gravatar image

updated 2014-12-12 11:51:48 -0500

I had similar problem as yours. Problem was that procedure on most sites was missing the installation of kernel-devel needed for akmod. kernel-devel was not dependency for some reason.

This worked for me after fresh install: 1.Install FPMFusion for Fedora 21 via RPM (I installed Free and Non Free) from here: http://rpmfusion.org/Configuration 2. Add negativo Nvidia repo yum-config-manager --add-repo=http://negativo17.org/repos/fedora-nvidia.repo 3. Install Kernel Devel yum -y install kernel-devel 4. Install Nvidia and akmod yum -y install nvidia-driver akmod-nvidia 5. yum update

Hope this helps

edit flag offensive delete link more
0

answered 2015-01-31 05:35:07 -0500

justexpect gravatar image

updated 2015-01-31 06:28:37 -0500

Hi,

For NVIDIA Corporation G98M [GeForce 9300M GS] Go to http://download1.rpmfusion.org/nonfree/fedora/updates/20/x86_64/ and download :

akmod-nvidia-331.113-1.fc20.x86_64.rpm

xorg-x11-drv-nvidia-331.113-1.fc20.x86_64.rpm

xorg-x11-drv-nvidia-libs-331.113-1.fc20.x86_64.rpm

then use

% sudo yum localinstall *nvidia*

Also install kernel-devel for your kernel (e.g 3.18.3-201.fc21.x86_64) and gcc

% sudo yum install kernel-devel gcc

It takes about 2 minutes for the driver to compile after a reboot. I get some nvidia driver crashes with kernel 3.18.3, you may want to try 3.17.*

edit flag offensive delete link more
0

answered 2014-12-12 08:30:13 -0500

radome gravatar image

I had a very similar issue that only presented when I tried to switch user. I discovered that after the installation of the NVIDIA drivers my system was left without an xorg.conf file. THis threw me because the system still worked on my dual monitor setup.

edit flag offensive delete link more

Comments

I was was using too on dual monitor setup, how did you fix it?

eyal6699 gravatar imageeyal6699 ( 2014-12-13 05:16:56 -0500 )edit

I simply renamed the nvidia.xorg.conf to xorg.conf and ran the Nvidia X Server Settings program. On the X Server Display Configuration tab there is a "Save to X Configuration File" button.

radome gravatar imageradome ( 2014-12-17 15:37:26 -0500 )edit
0

answered 2015-02-02 09:30:52 -0500

i tried the commands about nouveau and after the reboot got a unable to mount rootfs and the previous kernel no longer works

edit flag offensive delete link more
0

answered 2015-01-13 23:32:55 -0500

dylan gravatar image

rpmfusion have now added these packages in updates-testing:

yum install akmod-nvidia-340xx.x86_64 --enablerepo=rpmfusion-nonfree-updates-testing

You may need to edit your yum repo to point to the main site:

vim /etc/yum.repos.d/rpmfusion-nonfree-updates-testing.repo

Comment out the mirrorlist and uncomment the baseurl:

baseurl=http://download1.rpmfusion.org/nonfree/fedora/updates/testing/$releasever/$basearch/

edit flag offensive delete link more
0

answered 2015-02-05 05:58:06 -0500

justexpect gravatar image

There is kmod-nvidia-340xx moved from rpmfusion testing repository to main repository.

edit flag offensive delete link more
0

answered 2014-12-12 08:54:07 -0500

vodolaz095 gravatar image
edit flag offensive delete link more
0

answered 2014-12-12 08:26:05 -0500

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-12-12 05:23:36 -0500

Seen: 22,177 times

Last updated: Feb 05 '15