Ask Your Question

how do I change my hotspot name in fedora 21 to be displayed in other devices

asked 2015-01-04 06:40:32 -0500

mpduty gravatar image

the default name shown in other devices when my hotspot on fedora 21 is running is localhost.localdomain which I want to change. How can I do this?

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted

answered 2015-03-23 08:13:08 -0500

Libni Thomas gravatar image

updated 2015-03-23 08:15:14 -0500

I also searched for a solution to this for a while. It looks like this can't be done from the GUI. But it can definitely be done by changing the configuration file. I had to su to root, since other users can't edit this configuration file.

[user@l]$ su -

Then from the root prompt, vi to the file /etc/NetworkManager/system-connections/Hotspot

[root@l]# vi /etc/NetworkManager/system-connections/Hotspot

In this file you will see and entry SSID (name of the hotspot) among others like Security Key. Change SSID's value (after the = sign). Save and Quit Then I had to reboot to see the changes in effect (It did not change before the reboot)

edit flag offensive delete link more


Just restart your networkmanager, a system reboot is not necessary

Daiben gravatar imageDaiben ( 2016-01-24 10:54:44 -0500 )edit

answered 2015-01-10 20:54:22 -0500

catanzaro gravatar image

updated 2015-01-18 08:53:09 -0500

You can change your hostname in the Details panel of System Settings. You unfortunately have to do this before you create the hotspot for the first time.

The previous answer is wrong to suggest that it's possible to change the hotspot name from the Network panel. (Ideally that would be possible; someone just needs to implement it.)

edit flag offensive delete link more


Sorry, my bad.

SantoshHoropter gravatar imageSantoshHoropter ( 2015-01-11 15:43:28 -0500 )edit

You can reach your System Settings quickly with a right-click on the desktop.

florian gravatar imageflorian ( 2015-01-11 18:04:06 -0500 )edit

huh... really? when I right-click on my desktop, I didn't get any option of going to system settings. I usually go to top right corner and click, which I was lazy once and it ended up in me giving a wrong answer.

SantoshHoropter gravatar imageSantoshHoropter ( 2015-01-11 22:53:45 -0500 )edit

@SantoshHoropter. Sorry, can't upload a screenshot here but it works: Right-click on an empty desktop.

florian gravatar imageflorian ( 2015-01-13 18:13:34 -0500 )edit

sorry changing the hostname in the details panel of system settings does not change the hotspot name.

mpduty gravatar imagempduty ( 2015-01-18 02:43:42 -0500 )edit

answered 2016-08-16 12:57:07 -0500

Rudhin gravatar image

In Fedora 22, the hotspot files can be found in following path


ifcfg-Hotspot and keys-Hotspot

edit flag offensive delete link more

answered 2015-01-08 19:20:00 -0500

SantoshHoropter gravatar image

updated 2015-01-11 15:44:43 -0500

or , go to settings > details and you can change name there.

edit flag offensive delete link more



There is a utility, hostnamectl, that does all of the necessary changes that post talks about and probably some it missed.

randomuser gravatar imagerandomuser ( 2015-01-11 23:51:48 -0500 )edit

Thanks for your insight sir.

SantoshHoropter gravatar imageSantoshHoropter ( 2015-01-12 02:02:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2015-01-04 06:40:32 -0500

Seen: 4,441 times

Last updated: Mar 23 '15