Ask Your Question
0

How do you install httpd on Fedora 21 Server?

asked 2015-01-24 21:30:02 -0600

dverbrugge gravatar image

updated 2015-01-24 23:12:40 -0600

mether gravatar image

I have a fresh version of Fedora 21 Server. When I search for or try to install httpd with yum it says there is no package available. How would I go about finding out why it can't be found and getting it installed?

edit retag flag offensive close merge delete

Comments

With randomuser's help on irc, I've established that the physical ethernet connection I had was dead, and I tried another. I need to work with my IT department to get my internet connection functional. That should solve the problem.

dverbrugge gravatar imagedverbrugge ( 2015-01-25 21:17:06 -0600 )edit
1

@dverbrugge - will you mark sideburns answer as correct, since it does address the question as asked? We took another route troubleshooting your system, but other people might want to install httpd on Fedora and encounter this question.

randomuser gravatar imagerandomuser ( 2015-01-26 07:58:03 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
6

answered 2015-01-24 21:57:30 -0600

sideburns gravatar image

I just checked:

yum provides httpd

httpd-2.4.10-9.fc21.i686

The package is in the fedora repo, which is installed and active by default. Have you been doing anything non-standard with your list of repos?

edit flag offensive delete link more

Comments

I have not done anything with my list of repos. How would I go about checking to make sure they are functioning as they should be?

dverbrugge gravatar imagedverbrugge ( 2015-01-24 22:08:24 -0600 )edit
1

Run the command yum repolist enabled and you should see a line that starts with !fedora/21 If so, you have the appropriate repository enabled; if not we'll talk you through getting it enabled again.

sideburns gravatar imagesideburns ( 2015-01-24 23:34:35 -0600 )edit

When I run the command, I get repolist:0.

dverbrugge gravatar imagedverbrugge ( 2015-01-25 02:59:32 -0600 )edit
1

That seems to be saying that you don't have any repos enabled. Are you able to update your system?

sideburns gravatar imagesideburns ( 2015-01-25 03:52:39 -0600 )edit

It says nothing is marked for update.

dverbrugge gravatar imagedverbrugge ( 2015-01-25 03:57:57 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-24 21:30:02 -0600

Seen: 235 times

Last updated: Jan 24 '15