Ask Your Question
2

What is a virbr0 bridge connection?

asked 2015-04-07 18:04:50 -0500

k1monfared gravatar image

updated 2015-04-07 22:12:59 -0500

florian gravatar image

On my laptop time to time I notice that my wireless internet connection is very slow, or even I can't load any webpage, and when I check my connections I realize that I am connected to a Bridge network called virbr0, along with my home wireless network. Disconnecting the bridge network makes everything work, but now I am worried about the security of my netwrok. What is a bridge connection and how can I make sure it's my network is not compromised?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
3

answered 2015-04-07 20:55:09 -0500

florian gravatar image

The virbr0, or "Virtual Bridge 0" interface is used for NAT (Network Address Translation). It is provided by the libvirt library, and virtual environments (like Gnome Boxes or Virtualbox) sometimes use it to connect to the outside network (depending what network adapter you choose for the guest environment).

It was likely set-up with a VM software you installed at some point. If you'd like to remove it, and you're sure nothing else depends on it, you can use the following command:

sudo brctl delbr virbr0

edit flag offensive delete link more

Comments

1

@Florian Thank you very much for the explanation. I don't use any VM but how can I make sure that nothing else depends on it?

k1monfared gravatar imagek1monfared ( 2015-04-07 21:03:03 -0500 )edit
1

I am not sure how to do that in a smart way (with nice commands...) but here is a page from libvirt developer listing the apps that use the libvirt package/libraries. I am sure that list is not complete since Gnome Boxes is missing.

Did you use a VM in the past? The bridge could be a remain from it. Or did you use your PC as a WIFI hotspot or bridge?

florian gravatar imageflorian ( 2015-04-07 22:12:30 -0500 )edit
1

I also had vibr0 show up in my Fedora system at some point in the recent past. I haven't noticed anything odd performance wise. So is it OK to leave it?

passthejoe gravatar imagepassthejoe ( 2015-04-08 16:27:38 -0500 )edit
1

No, I didn't use either one of them. I used sudo ifconfig virbr0 down and then your command to delete it. Thanks.

k1monfared gravatar imagek1monfared ( 2015-04-08 22:49:01 -0500 )edit
1

@passthejoe: Totally OK to keep it!

florian gravatar imageflorian ( 2015-04-10 08:05:31 -0500 )edit
3

answered 2016-11-27 09:55:32 -0500

ylec gravatar image

The answer above : brctl delbr virbr0 or ifconfig virbr0 down do the job temporarily; cause they act on kernel space. If you want to disable it for each reboot, you must search the exact reason. Mee too I have it, and I have choosen to keep it, as long as my other virtual networks in VirtualBox, do not require the same subnet address than virbr0

In Fedora, once you have installed KVM, or maybe an other open source Virtualization software probably libvirt service is running; this service configure a default bridge virbr0, providing : a bridge, connected to a virtual router providing , a dhcp service, and routing+NAT from this bridge to your main interface. So any virtual machine connected to this bridge has direct access to internet, if its interface is in dhcp mode.

VMware, VirtualBox have their own feature: bridge+DHCP+routing+NAT. +++ Which application could use my virbr0 ? check something like:

# find /etc | xargs fgrep virbr0 2> /dev/null

/etc/libvirt/qemu/networks/default.xml: <bridge name="virbr0"/>

/etc/libvirt/qemu/networks/autostart/default.xml: <bridge name="virbr0"/>

/etc/qemu/bridge.conf:allow virbr0

OK qemu could use virbr0, if KVM is available. But only VirtualBox or exclusive KVM can use accelerated hardware required by 64bits VM guest! I using mainly VirtualBox ==> virbr0 will not be used !

+++ ANYWAY for your own reason, now that your are sure that the current hypervisor you are using do not need virbr0, remove it definitively if you want:

check

# systemctl status libvirtd * libvirtd.service - Virtualization daemon Loaded: loaded (/usr/lib/systemd/system/libvirtd.service; enabled; vendor preset: enabled) Active: active (running) since Sun 2016-11-27 10:56:49 CET; 4h 55min ago ... etc ...

==> stop it and disable it

# systemctl stop libvirtd

# systemctl disable libvirtd

The virbr0 will not be destroyed by this action, nor the dnsmasq process will stop now. But when you reboot the system, you will not see them! If you want to remove it immediately , do it as suggested above with brctl

edit flag offensive delete link more
0

answered 2016-04-29 09:27:53 -0500

thanks, work for me (CentOS 7). Obrigado, funcionou pra mim (pt-br) marcelo

edit flag offensive delete link more

Comments

Valeu meu irmao

florian gravatar imageflorian ( 2016-11-27 20:21:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-07 18:04:50 -0500

Seen: 29,851 times

Last updated: Nov 27 '16