Ask Your Question
2

How do I start a new firefox windo, instead of moving it?

asked 2015-04-13 14:25:01 -0600

ErikE gravatar image

Hello all,

I'm using the Xfce spin of Fedora 20. Until recently, if I first started Firefox in one workspace, and then moved to another workspace, and started firefox again via the application menu, it would start a new window for me. Starting recently however, it will instead move the window I already had to the new workspace, which is not what I want. Why does it do that? Is there some way to get back the original behaviour?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2015-04-13 15:18:57 -0600

sideburns gravatar image

Welcome to ask.fedora, and thanx for asking a well-framed question, instead of leaving people to guess what you meant. I don't know exactly how to do what you want, but I do know a way to get a new Firefox window to open on a different workspace. Put your mouse over the workspace you want the window to open on, but don't click. Use ^N to open a new window, then click the mouse, changing to the other workspace and that's where your new Firefox window will open. I suggest doing it this way, rather than using File->New Window and then switching workspaces because unless you're very fast (or at least, faster than I am) the window will open up next to the old one instead of where you want it.

edit flag offensive delete link more

Comments

Yup, that works - thanks for the tip! Didn't know about that one.

Meanwhile, I also discovered something myself. My description in my original post was a bit sloppy: when I "started firefox via the application menu", I was using the "web browser" menu item (I have firefox as my "preferred web browser"), rather then firefox's "own" menu item (below "internet"). If I, however, use Firefox's own menu item instead, I get the behaviour I want.

ErikE gravatar imageErikE ( 2015-04-15 16:44:22 -0600 )edit
0

answered 2015-04-15 17:01:46 -0600

ErikE gravatar image

(after some more digging ...)

To start with my latter question: "how do I get the original behaviour back?": As I already wrote in a comment to sideburns above: start firefox using its own menu item is one way. Another way is to not configure Firefox to "open new windows in a new tab instead".

Regarding my question "why": When using the "Web browser" menu item, whatever browser you have configured as your "preferred browser" is started using the command "exo-open --launch web-browser". Apparently, if you have configured Firefox to open new windows in a new tab instead, exo-open won't start a new window if one already exist - not even if the existing window is in another workspace - but start a new tab in the already existing window - moving it first if it was in another workspace.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-13 14:25:01 -0600

Seen: 140 times

Last updated: Apr 15 '15