Ask Your Question
1

How to install "bundle" with "gem" on Fedora 22

asked 2015-06-05 14:20:53 -0500

wis775 gravatar image

I am going to change some color settings on the Adwaita Theme.

Adwaita's readme says:

To be able to use the lates/adequate version of sass, install ruby, gem, sass & bundle. On Fedora F20, this is done with sudo dnf install rubygems && gem install bundle && bundle install from the same directory this README resides in.

So, I tried this on my Fedora 22 machine

sudo dnf install rubygems

This was successful. But the second statement ends in an error

 gem install bundle

Ignoring json-1.8.2 because its extensions are not built. Try: gem pristine json --version 1.8.2 ERROR: Loading command: install (LoadError) no such file to load -- jopenssl/load ERROR: While executing gem ... (NoMethodError) undefined method `invoke_with_build_args' for nil:NilClass

How can I solve this?

Thx.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-06-05 19:49:53 -0500

aeperezt gravatar image

You need to install it as

sudo dnf rubygem-bundler

Since you are in that will recommend to also install

sudo dnf install ruby-devel mariadb-devel

So when running bundle it will compile fine needed gems.

edit flag offensive delete link more

Comments

Thank you - it works :-) The complete steps based on your suggestion:

sudo dnf install rubygems rubygem-bundler ruby-devel mariadb-devel
gem install bundle
bundle install

After this I could run ./parse-sass.sh in the Adwaita direcotry.

wis775 gravatar imagewis775 ( 2015-06-06 04:36:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-05 14:20:53 -0500

Seen: 5,143 times

Last updated: Jun 05 '15