Ask Your Question
3

How to stop plasmashell from eating too much CPU time?

asked 2015-06-13 11:41:05 -0500

kumiponi gravatar image

updated 2015-12-08 19:34:52 -0500

Almost every time I'm doing something CPU-intensive (like playing a game) I have to kill the plasmashell process because it takes so much CPU power, even when sitting idle. It seems to worsen over time, so that if plasmashell is left running long enough, everything slows to a crawl and the cooling fan is begging for mercy. There may be several bugs involved – I don't know what triggers it in my case. Can you recommend some settings to turn on or off?

EDIT: Unfortunately, after using F23 for a while now, it came back. :( Plasmashell is again using about 30% of a CPU core (according to top) while idle, i.e. no GUI programs other than the desktop running. I have installed various packages when I've needed them, but it's hard to say if I've triggered the issue again somehow. It's most noticeable when using the Pepper Flash plugin (From Google Chrome) – animation becomes choppy.

EDIT 2: I narrowed some of it down to the analog clock plasmoid that I was using on the desktop background. Maybe it has been the main resource hog and runs inside the "plasmashell" process.

edit retag flag offensive close merge delete

Comments

Very strange. I don't have this kind of problems ... What about your hardware?

EllePi gravatar imageEllePi ( 2015-06-13 12:56:32 -0500 )edit

The computer is Lenovo T440p and it has a GeForce GT 730M graphics card. Video drivers installed by default are nouveau and i915 (= intel, handles OpenGL). The problem may have lessened a little with recent updates, but it still persists.

kumiponi gravatar imagekumiponi ( 2015-06-13 18:20:53 -0500 )edit
1

There has been some new develpments. Apparently a bug in the Intel graphics stack is causing Plasma crashes. It may or may not be related. Article in Slashdot

kumiponi gravatar imagekumiponi ( 2015-08-06 10:05:44 -0500 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2015-11-21 12:36:46 -0500

kumiponi gravatar image

This issue seems to have been completely resolved in F23. I don't know what the problem was, so I can only guess that it was a graphics driver bug.

edit flag offensive delete link more
1

answered 2015-07-20 05:20:40 -0500

if you have any process monitoring widgets on your screen (CPU, network, etc), try removing them to see if it helps. I discovered a similar problem with plasmashell at 30-50% CPU usage. After removing a CPU load monitor widget, plasmashell's CPU usage dropped back down to more reasonable levels.

Found a few similar sounding issues reported in the KDE Bugzilla

edit flag offensive delete link more
0

answered 2015-12-27 17:17:37 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I deleted the Analog Clock widget from the desktop and it immediately solved the problem for me. plasmashell had three processes running and the first two processes utilized the highest CPU consuming over 50% between the two of them. I deleted the clock widget and both those processes disappeared (using htop to monitor) and the only remaining plasmashell process is using 15% CPU.

I then deleted the comics widget from the desktop and the CPU utilization for the last plasmashell process dropped to 2% with the occasional spike to ~15%.

Clearly the issue is related to desktop widgets.

Gary D.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

4 followers

Stats

Asked: 2015-06-13 11:41:05 -0500

Seen: 9,276 times

Last updated: Dec 08 '15