Ask Your Question
0

Can't remove preupgrade (Fedora 17)

asked 2012-11-28 07:31:29 -0500

mihkel gravatar image

updated 2013-06-04 00:16:19 -0500

Hi.

Since preupgrade is considered deprecated for Fedora 18 upgrade, I thought I don't need it any more in my system. So I went ahead and tried to remove it. But this happend:

 # yum erase preupgrade
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package preupgrade.noarch 0:1.1.10-2.fc17 will be erased
--> Processing Dependency: preupgrade for package: PackageKit-0.7.5-1.fc17.x86_64
--> Running transaction check
---> Package PackageKit.x86_64 0:0.7.5-1.fc17 will be erased
--> Processing Dependency: PackageKit = 0.7.5-1.fc17 for package: PackageKit-yum-0.7.5-1.fc17.x86_64
--> Processing Dependency: PackageKit for package: PackageKit-yum-plugin-0.7.5-1.fc17.x86_64
--> Processing Dependency: PackageKit >= 0.5.0 for package: gnome-packagekit-3.4.2-1.fc17.x86_64
--> Processing Dependency: PackageKit = 0.7.5-1.fc17 for package: PackageKit-glib-0.7.5-1.fc17.x86_64
--> Running transaction check
---> Package PackageKit-glib.x86_64 0:0.7.5-1.fc17 will be erased
--> Processing Dependency: libpackagekit-glib2.so.14()(64bit) for package: PackageKit-command-not-found-0.7.5-1.fc17.x86_64
--> Processing Dependency: libpackagekit-glib2.so.14()(64bit) for package: gnome-settings-daemon-3.4.2-3.fc17.x86_64
--> Processing Dependency: libpackagekit-glib2.so.14()(64bit) for package: PackageKit-gstreamer-plugin-0.7.5-1.fc17.x86_64
--> Processing Dependency: PackageKit-glib = 0.7.5-1.fc17 for package: PackageKit-device-rebind-0.7.5-1.fc17.x86_64
--> Processing Dependency: PackageKit-glib = 0.7.5-1.fc17 for package: PackageKit-command-not-found-0.7.5-1.fc17.x86_64
--> Processing Dependency: PackageKit-glib = 0.7.5-1.fc17 for package: PackageKit-gstreamer-plugin-0.7.5-1.fc17.x86_64
---> Package PackageKit-yum.x86_64 0:0.7.5-1.fc17 will be erased
---> Package PackageKit-yum-plugin.x86_64 0:0.7.5-1.fc17 will be erased
---> Package gnome-packagekit.x86_64 0:3.4.2-1.fc17 will be erased
--> Running transaction check
---> Package PackageKit-command-not-found.x86_64 0:0.7.5-1.fc17 will be erased
---> Package PackageKit-device-rebind.x86_64 0:0.7.5-1.fc17 will be erased
---> Package PackageKit-gstreamer-plugin.x86_64 0:0.7.5-1.fc17 will be erased
---> Package gnome-settings-daemon.x86_64 0:3.4.2-3.fc17 will be erased
--> Processing Dependency: gnome-settings-daemon >= 2.21.92 for package: 1:gdm-3.4.1-3.fc17.x86_64
--> Processing Dependency: gnome-settings-daemon >= 2.21.91-3 for package: 1:control-center-3.4.2-4.fc17.x86_64
--> Running transaction check
---> Package control-center.x86_64 1:3.4.2-4.fc17 will be erased
--> Processing Dependency: control-center for package: 1:gnome-bluetooth-3.4.2-1.fc17.x86_64
--> Processing Dependency: control-center for package: orca-3.4.2-1.fc17.x86_64
---> Package gdm.x86_64 1:3.4.1-3.fc17 will be erased
--> Processing Dependency: gdm for package: pulseaudio-gdm-hooks-1.1-9.fc17.x86_64
--> Processing Dependency: gdm >= 1:2.22.0 for package: pulseaudio-gdm-hooks-1.1-9.fc17.x86_64
--> Running transaction check
---> Package gnome-bluetooth.x86_64 1:3.4.2-1.fc17 will be erased
--> Processing Dependency: dbus-bluez-pin-helper for package: bluez-4.99-2.fc17.x86_64
--> Processing Dependency: libgnome-bluetooth-applet.so.0()(64bit) for package: gnome-shell-3.4.1-6.fc17.x86_64
---> Package orca.x86_64 0:3.4.2-1.fc17 will be erased
---> Package pulseaudio-gdm-hooks.x86_64 0:1.1-9.fc17 will be erased
--> Running transaction check
---> Package bluez.x86_64 0:4.99-2.fc17 will be erased
--> Processing Dependency: bluez >= 4.34 for package: pulseaudio-module-bluetooth-1.1-9.fc17.x86_64
---> Package gnome-shell.x86_64 0:3.4.1-6.fc17 will be erased
--> Processing Dependency: gnome-shell ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-11-28 09:31:25 -0500

hhlp gravatar image

This is a perfect question, to report a Bug. Feel to report in Red Hat Bugzilla... against preupgrade

edit flag offensive delete link more
0

answered 2013-06-04 00:15:37 -0500

This was a known bug, which has since been fixed, at least in Fedora 19.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-28 07:31:29 -0500

Seen: 329 times

Last updated: Jun 04 '13