Ask Your Question
1

kernel name problem

asked 2011-12-08 04:18:56 -0500

toy gravatar image

I am using fedora 16. Old kernel version is 3.1.2 then updated to 3.1.4 and I removed 3.1.2 but when booted, the screen still showed then name 3.1.2. Do you have the same situation?

edit retag flag offensive close merge delete

Comments

Did you remove the kernel or kernel entry from the grub ?

SoumyaC gravatar imageSoumyaC ( 2011-12-08 08:01:23 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2011-12-12 04:11:36 -0500

makuz gravatar image

It is probably just an incorrect display of the kernel name in grub. I also noticed this behaviour. You can verify this by pressing 'e' in the grub menu. Mine looks like this:

setparams 'Fedora (3.1.4-1.fc16.i686)'
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_gpt
        insmod ext2
        set root='(hd0,gpt4)'
        search --no-floppy --fs-uuid --set=root 05ce3f0b-18fb-44e3-ae82-9c6671701e50
        echo 'Loading Fedora (3.1.1-2.fc16.i686)'
        linux   /vmlinuz-3.1.4-1.fc16.i686 root=/dev/mapper/VolGroup-lv_root ro rd.md=0 rd.dm=0 rd.lvm.lv=VolGroup/lv_swap SYSFONT=latarcyrheb-sun16 rd.lvm.lv=VolGroup/lv_root rd.luks=0 KEYTABLE=us LANG=en_US.UTF-8 nouveau.modeset=0 rd.driver.blacklist=nouveau
        echo 'Loading initial ramdisk ...'
        initrd /initramfs-3.1.4-1.fc16.i686.img

As you can see, it's the 3.1.4 kernel, but the echo line reads 'Loading Fedora (3.1.1-2.fc16.i686)'. I think it does not cause any problems. It's a bug reported here: https://bugzilla.redhat.com/show_bug.cgi?id=732654

edit flag offensive delete link more
0

answered 2011-12-08 04:48:52 -0500

hhlp gravatar image

updated 2011-12-10 05:09:02 -0500

You have to add these two lines to your "/etc/default/grub" file:

GRUB_DEFAULT=0
GRUB_SAVEDEFAULT=true

try to update your grub.cfg with this command

 sudo grub2-mkconfig -o /boot/grub2/grub.cfg

source #bugzilla732058

edit flag offensive delete link more

Comments

please post your /boot/grub2/grub.cfg and you /etc/default/grub and update your post with the information of these files ... please use the correct mark-up to make it readable

hhlp gravatar imagehhlp ( 2011-12-09 08:12:37 -0500 )edit
-1

answered 2011-12-12 08:05:10 -0500

ztank1013 gravatar image

updated 2011-12-14 07:20:47 -0500

If you run uname -a after the OS loaded you should see the correct kernel version loaded. In fact it is just a bug as @makuz correctly reported in his answer.

If you like to fix/workaround it just do the following (carefully!).

Edit as root the /etc/grub2.cfg read only file and replace the line:

echo 'Loading Fedora (3.1.1-2.fc16.x86_64)'

with

echo 'Loading Fedora (3.1.4-1.fc16.x86_64)'

Then run the following command to update your grub configuration:

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

Reboot and see if the message is now correct.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-12-08 04:18:56 -0500

Seen: 635 times

Last updated: Dec 14 '11