Ask Your Question
0

Virt-manager not show lxc

asked 2015-06-23 13:36:46 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Hello,

A few days ago I upgraded to Fedora22 and does not appear in virt-manager option lxc connection. Virt-manager showed them in Fedora21 not remember having to do anything special. Is it normal for version change? What am I missing?

It's not important, but it is convenient and fast to perform some remote management tasks using lxc + ssh.

Thanks.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2015-06-24 03:05:39 -0500

Juan Antonio Clavero García gravatar image

updated 2015-06-28 13:22:07 -0500

if it's the first thing I checked and i have installed libvirtd-daemon-lxc-1.2.13 and libvirtd is active and running.

That is correct but the problem continues.

Thanks.

Virt-manager running the option --connect executed properly what I need, then it is a matter of marking the option to auto-connect to the details of the connection.

edit flag offensive delete link more

Comments

Just to make that clear, the workaround is:

virt-manager --connect lxc://

then enable Autoconnect for the LXC connection. Works fine here on Fedora 22.

jakob123 gravatar imagejakob123 ( 2015-08-02 05:22:07 -0500 )edit
0

answered 2015-06-23 14:55:53 -0500

aeperezt gravatar image

Review that you have installed libvirt-daemon-lxc and make sure libvirtd is started if not

sudo dnf install libvirt-daemon-lxc.

sudo systemctl restart libvirtd

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-06-23 13:36:46 -0500

Seen: 2,349 times

Last updated: Jun 28 '15