Ask Your Question
1

Installing almost anything.

asked 2015-06-30 20:22:37 -0600

makro gravatar image

I am still struggling with Fedora. Nearly anything I try to install gets met with the "sorry, that didn't work" message. Fedora has a lot of plain, white bread boring apps, and I understand that they don't want to infringe on copyrights or anything, but most of the stuff I want to install is already out there copyright free and readily available in other Linux distros and apparently, already installed in Fedora by most of you. I am an animator and videographer, so I want media codecs and some animation programs. Any suggestions for installing this stuff? I tried to update and install free and non free repositories, tried to install from website downloads, tried to follow suggestions here and so far, nothing works. Even those articles about the next 11 steps after installing Fedora and stuff like that suggests that any trained monkey can install all these programs, but I guess I am not trained well enough yet.

Thanks for any help!!!

edit retag flag offensive close merge delete

Comments

I recommend you read specific guides for the version of Fedora. Example if you have Fedora 22, then search a guide for Fedora 22. The world is changing.

davidva gravatar imagedavidva ( 2015-07-01 22:27:08 -0600 )edit

Thanks, davidva! Lots happened, lots of new stuff installed, but it won't run Postinstallerf. I got the normal sorry this didn't work message. Could this be because I ran postinstallerf as one of the fixes attempted before? Can I remove it, even though I don't see it in the software lists?

Thanks, once again! I feel like progress is being made!

makro gravatar imagemakro ( 2015-07-01 22:38:41 -0600 )edit

@makro PostInstallerF doesn't use dropbox and livna repositories since Fedora 20. This is a case of other application. If some program isn't available for Fedora, The team PostInstallerF builds your own rpm; they maintain constant updates. PostInstallerF maintains a policy of not repackage any official program. In this way conflicts are avoided.

davidva gravatar imagedavidva ( 2015-07-02 00:15:12 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2015-06-30 20:32:17 -0600

sideburns gravatar image

It may be easiest for you to use some of these setup guides. Several of the scripts include installing the rpmfusion repos to get the various things that Fedora can't offer directly for various reasons. If you're still having issues after you're done with the setup guides, please give us more information about what's going wrong, either by editing your question, or as a comment. Good luck, and let us know how everything goes.

edit flag offensive delete link more

Comments

I have fedy. It offers a multimedia codec package. When I try to install them, I get the message: Multimedial codecs (install) failed.

makro gravatar imagemakro ( 2015-07-01 21:53:12 -0600 )edit
2

answered 2015-07-01 21:47:24 -0600

makro gravatar image

Thanks, sideburns! I have been trying a lot of guides since I've installed Fedora, but I will try those you've suggested ASAP. Here's how one session went:

[mike@localhost ~]$ sudo dnf install --nogpgcheck http://download1.rpmfusion.org/free/f... [sudo] password for mike: Failed to synchronize cache for repo 'livna' from 'http://rpm.livna.org/mirrorlist': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, disabling. Failed to synchronize cache for repo 'Dropbox' from 'http://linux.dropbox.com/fedora/22/': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, disabling. Last metadata expiration check performed 1:52:11 ago on Wed Jul 1 20:17:33 2015. Package rpmfusion-free-release-22-1.noarch is already installed, skipping. Dependencies resolved. Nothing to do. Complete! [mike@localhost ~]$ sudo dnf install --nogpgcheck http://download1.rpmfusion.org/nonfre... [sudo] password for mike: Failed to synchronize cache for repo 'livna' from 'http://rpm.livna.org/mirrorlist': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, disabling. Failed to synchronize cache for repo 'Dropbox' from 'http://linux.dropbox.com/fedora/22/': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, disabling. Last metadata expiration check performed 2:04:25 ago on Wed Jul 1 20:17:33 2015. Package rpmfusion-nonfree-release-22-1.noarch is already installed, skipping. Dependencies resolved. Nothing to do. Complete! [mike@localhost ~]$ sudo rpm -ivh http://download1.rpmfusion.org/free/f... Retrieving http://download1.rpmfusion.org/free/f... warning: /var/tmp/rpm-tmp.dpMkW6: Header V3 RSA/SHA256 Signature, key ID ae688223: NOKEY Preparing... ################################# [100%] package rpmfusion-free-release-22-1.noarch (which is newer than rpmfusion-free-release-20-1.noarch) is already installed file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora from install of rpmfusion-free-release-20-1.noarch conflicts with file from package rpmfusion-free-release-22-1.noarch file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-latest from install of rpmfusion-free-release-20-1.noarch conflicts with file from package rpmfusion-free-release-22-1.noarch file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-rawhide from install of rpmfusion-free-release-20-1.noarch conflicts with file from package rpmfusion-free-release-22-1.noarch [mike@localhost ~]$ sudo dnf remove rpmfusion-free-release-20-1.noarch No match for argument: rpmfusion-free-release-20-1.noarch Error: No packages marked for removal. [mike@localhost ~]$ sudo remove file/etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora sudo: remove: command not found [mike@localhost ~]$ ^C [mike@localhost ~]$ ^C [mike@localhost ~]$

...and this:

[mike@localhost ~]$ sudo dnf install vlc [sudo] password for mike: Failed to synchronize cache for repo 'livna' from 'http://rpm.livna.org/mirrorlist': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, disabling. Failed to synchronize cache for repo 'Dropbox' from 'http://linux.dropbox.com/fedora/22/': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, disabling. Last metadata expiration check performed 2:26:16 ago on Wed Jul 1 20:17:33 2015. No package vlc available. Error: no package matched: vlc [mike@localhost ~]$

I tried to remove the older repositories which it says are conflicting, but no luck with that.

I will try your suggestions. Onward and upward. Thanks!

edit flag offensive delete link more

Comments

If Fedy doesn't work, try AutoTen. (It was first written for F 10, and updated as needed.) It will, among other things, tell you what's installed and what isn't and uninstall packages you decide you don't need. As far as your issues with Fedy, it may have F 20 hard coded into it, which won't work with newer versions.

sideburns gravatar imagesideburns ( 2015-07-01 22:03:24 -0600 )edit
1

answered 2015-07-01 22:14:35 -0600

davidva gravatar image

updated 2015-07-01 22:30:39 -0600

@makro don't worry!

You need remove dropbox and livna repositories.

Why dropbox? Because, now is maintained officially by Fedora

su
rm -f /etc/yum.repos.d/dropbox.repo

Why livna? because livna provides a obsolete and old version of libdvdcss and your repository doesn't exist for Fedora 22

dnf -y remove livna-release

Now update

dnf clean metadata && dnf -y update
edit flag offensive delete link more

Comments

After, you can use PostIntallerF and install all necessary.

davidva gravatar imagedavidva ( 2015-07-01 22:17:18 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-30 20:22:37 -0600

Seen: 2,041 times

Last updated: Jul 01 '15