Ask Your Question
1

Why is my wireless not recognized?

asked 2015-07-12 09:40:48 -0500

AlessioTS gravatar image

updated 2015-07-14 18:33:49 -0500

mether gravatar image

The wireless card is not recognized. The laptop in an asus F550LD. I've already tried several (if not all) the combinations of packages and commands that I've found on the forums but none seems to work. I guess I'm doing something wrong or I'm missing something.

This is what I know:

It's Fedora22, installed in dual-boot with win8.1, this is the kernel:

# uname -r
4.0.7-300.fc22.x86_64
And this is my wireless card:
#lspci | grep -i broadcom
03:00.0 Network controller: Broadcom Corporation BCM43142 802.11b/g/n (rev 01)

I've installed from RPMfusion the packages that are suggested:

#rpm -qa | grep -- -wl
kmod-wl-4.0.4-301.fc22.x86_64-6.30.223.248-8.fc22.1.x86_64
broadcom-wl-6.30.223.248-2.fc22.noarch
kmod-wl-6.30.223.248-8.fc22.1.x86_64
akmod-wl-6.30.223.248-8.fc22.1.x86_64
kmod-wl-4.0.7-300.fc22.x86_64-6.30.223.248-8.fc22.1.x86_64

When I run this, nothing good happens:

# modprobe wl
modprobe: ERROR: could not insert 'wl': Required key not available

# modinfo wl
filename:       /lib/modules/4.0.7-300.fc22.x86_64/extra/wl/wl.ko
license:        MIXED/Proprietary
alias:          pci:vdsvsdbc02sc80i*
depends:        cfg80211
vermagic:       4.0.7-300.fc22.x86_64 SMP mod_unload 
parm:           passivemode:int
parm:           wl_txq_thresh:int
parm:           oneonly:int
parm:           piomode:int
parm:           instance_base:int
parm:           nompc:int
parm:           intf_name:string

# rfkill list all
0: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: asus-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

Somewhere I red that this might be a solution and, of course, I tried:

modprobe iwlwifi 11ndisable=1
echo options iwlwifi 11ndisable=1 > /etc/modprobe.d/iwlwifi.conf
eventually it didn't work and I removed the file iwlwifi.conf.

Additionally, since the card has no physical switch, I've red somewhere to add a file nemed: asus-wifi.conf in /etc/modprobe.d/ with the following string:

options asus_nb_wmi wapf=1
As a consequence, the LED-light of the wifi card went on...and that's the greatest success of the last 2 days :)

Is anybody having a clue of what is wrong here?

Tnx Alessio

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
2

answered 2015-07-12 10:39:47 -0500

aeperezt gravatar image

You need to install rpmfusion.org and install kmod or akmod-wl the difference will be that akmod-wl will install and update every time you update the kernel while kmod will need to wait until new kernel module is compile on rpmfusion.

edit flag offensive delete link more

Comments

Tnx. I guess that they should be already installed. I mean: they appear in the list above.

AlessioTS gravatar imageAlessioTS ( 2015-07-12 10:57:30 -0500 )edit

You are right one thing do you must have kmod or akmod-wl but not both. Think that could be you issue.

aeperezt gravatar imageaeperezt ( 2015-07-12 11:21:51 -0500 )edit

I removed the packages above and installed again only akmod-wl, and the situation is now the following:

# dnf install akmod-wl

rpm -qa | grep -- -wl

broadcom-wl-6.30.223.248-2.fc22.noarch akmod-wl-6.30.223.248-8.fc22.1.x86_64

rebooting and doing modprobe, something changed:

# modprobe wl
modprobe: FATAL: Module wl not found.

Still no signs of life from the wireless though. Perhaps the problem is somewhere else...beside the user :)

AlessioTS gravatar imageAlessioTS ( 2015-07-12 11:52:47 -0500 )edit

Do you have kernel-devel package and devel tools?

aeperezt gravatar imageaeperezt ( 2015-07-12 12:03:57 -0500 )edit

Now I do: I've done this

# dnf install kernel-devel

I rebooted and still nothing

AlessioTS gravatar imageAlessioTS ( 2015-07-12 12:39:03 -0500 )edit
2

answered 2015-07-12 12:51:19 -0500

aeperezt gravatar image

Sorry forgot to ask do you have UEFI secure mode active because all rpmfusion modules are not sign and because of that secure mode will not allow to load them

edit flag offensive delete link more
0

answered 2015-07-12 11:42:19 -0500

kmod or akmod-wl DO NOT WORK! i repeat they do NOT work. Ive done anything and everything on my dell inspiron. Just about no linux will recognize 43142. After days of all that i ended up buying a USB-WiFi thingy which i use specifically for my linux(s) //triple boot. itl cost a mere INR 700.. usd idk what.. just buy it and get it over with.

edit flag offensive delete link more
0

answered 2016-04-20 22:33:19 -0500

TNAndy gravatar image

I had to disable "secure boot" in my UEFI BIOS in order to get the wireless to work. Apparently, the wireless is unsigned (I'm not entirely sure what signing entails). As long as it's unsigned, the wireless will not work with secure boot. I disabled my secure boot flag and now the wireless works. (Note secure boot is not the same thing as legacy boot. If you have a UEFI BIOS and are dual booting, both windows and linux must be installed in UEFI mode and NOT in legacy boot mode.)

If anyone has any advice about signing a kernel module so I can turn secure boot back on, I'd love to hear from you.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-12 09:40:48 -0500

Seen: 2,764 times

Last updated: Jul 14 '15