Ask Your Question
1

Samba shares appear as empty on network

asked 2012-06-21 12:16:11 -0500

matthewp gravatar image

updated 2014-09-28 23:58:04 -0500

mether gravatar image

I am attempting to set up a couple of samba shares so that anyone on the network can access them (without username/password). However when I try to access them from another computer, they appear to be empty. Couple of things of note:

  • I have a nobody samba user but not a nobody linux user. Is that important?
  • I have this exact same (even directory names are the same) set up on a Ubuntu box without issues.
  • I have the firewall disabled for now.

My smb.conf file is here:

http://pastie.org/4127429

edit retag flag offensive close merge delete

Comments

security needs to be "user"

There is an great tutorial for setting up Samba on Fedora already answered here: https://ask.fedoraproject.org/en/question/40353/how-to-enable-samba-share-for-a-specific-directory-fedora-20/

This answer gives indept explanation on how to create share, setup firewall to let users connect to your samba server and how to disable selinux from blocking samba. Good luck.

valentt gravatar imagevalentt ( 2014-05-31 16:32:59 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-10-07 05:48:41 -0500

ADB gravatar image

Hello,

I notice that you are using "security=domain". If you are using Microsoft Active Diectory, try "security=ads" (I can guide you, it's more difficult) else where use "security=user". In the case of security=user, the user must exist in the linux user database and in the samba user database.

The user nobody must exist in the /etc/passwd and /etc/shadows; normaly it was create.

Try in a first step to give all unix right on the directory and his content. For example, the directory is /home/user : chmod -R 777 /home/user or give the correct right to it. The Linux user nobody must access to that directory in case of public=yes.

For my part I use the Linux user smbuser with no access under Linux and I force the samba user to be smbuser of the share "force user = smbuser". Try the directory to be owned by samba/linux user : chown -R smbuser /home/user chmod -R 700 /home/user

Notice that to access a smb server from windows by the browsing, Windows try to authenticate you on the samba server with the couple user/password of you Windows session.

Try direct access in the windows browser like \\server\public. "server" = netbios name = linux hostname wihout domain suffix Or use command line like "net use h: \\server\public"

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-06-21 12:16:11 -0500

Seen: 6,490 times

Last updated: Oct 07 '12