Ask Your Question
0

journalctl --list-boots stuck and using 100% CPU.

asked 2015-07-18 05:11:40 -0500

fat-lobyte gravatar image

updated 2015-07-18 05:22:11 -0500

Hi!

My problem is simply described: I wanted to list all the boots in the journal, so I ran journalctl --list-boots. The application does not finish and is permanently at 100 % cpu usage.

I have limited the disk usage to 2GB and journalctl --disk-usage reports

Archived and active journals take up 2.1G on disk.

I ran journalctl --verify, and came up with a few corrupt log files. I deleted those, but the problem still persists.

Does anyone have an idea what is going on?

edit retag flag offensive close merge delete

Comments

Thanks, I vacuumed it down to a size of 1 GB and now the boots are displayed correctly, almost instantly.

fat-lobyte gravatar imagefat-lobyte ( 2015-07-19 21:24:20 -0500 )edit

Nice. If you could formulate an answer from it worked, please post.

NuuN gravatar imageNuuN ( 2015-07-19 22:04:24 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-07-18 15:21:13 -0500

NuuN gravatar image

Apparently, we do not. A binary logger is new ground. Most of us are used to ascii logs. Do these things to begin with: #journalctl --vacuum-size

#journalctl --header | fpaste --confirm

For the latter, check for information leaks if you have sensitive information.

I suspect fragmentation or bottle-necking in some of the file operations.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-07-18 05:11:40 -0500

Seen: 520 times

Last updated: Jul 18 '15