Hiding text shown during transition from plymouth to gdm

asked 2015-08-13 21:06:22 -0500

How can one hide between the transition from the plymouth splash screen and the display manager?

More specifically, here's my situation. I once used the nouveau graphic drivers, but after I decided to switch to the nvidia drivers for my GEforce GT720 graphics card. I followed the tutorial at http://www.if-not-true-then-false.com... to install the akmod, modifying it appropriately for my system, as I use UEFI with secure boot. Mainly, th only modifications I made to their instructions was that I signed the nvidia driver and I used the appropriate path to grub.cfg for a secure boot system (which is /boot/efi/EFI/fedora/grub.cfg on my system). Everything worked fine, but here's the problem.

When I boot up, the transition between plymouth and gdm is not as smooth as it should be. In between the time plymouth quits and fedora starts up, a wall of text is displayed on my screen, including things like "Starting GNOME display manager..." and "Started Network Manager...", etc. What I need to know is how to hide the text or at the very least, make the transition smoother.

Some info about my system:

$ uname -a

Linux fedora 4.1.4-200.fc22.x86_64 #1 SMP Tue Aug 4 03:22:33 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

$ cat /etc/default/grub

GRUB_VIDEO_BACKEND="vbe"

GRUB_FONT_PATH="/boot/efi/EFI/fedora/fonts/unicode.pf2"

GRUB_GFXMODE="1920x1080x32"

GRUB_TIMEOUT=5

GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"

GRUB_DEFAULT=saved

GRUB_DISABLE_SUBMENU=true

GRUB_TERMINAL_OUTPUT="gfxterm"

GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/swap rd.lvm.lv=fedora/root rhgb quiet"

GRUB_DISABLE_RECOVERY="true"

GRUB_GFXPAYLOAD_LINUX="keep"

I know it's a lot, and this is what I get for using proprietary drivers, but thank you for any help.

edit retag flag offensive close merge delete

Comments

I confirm that I have the same problem, please help.

Leronez gravatar imageLeronez ( 2016-02-29 11:17:03 -0500 )edit