Ask Your Question
1

Mounting issue switching from Win8 to Fedora

asked 2015-08-25 19:56:40 -0500

SweaterNinja gravatar image

updated 2015-08-27 22:29:34 -0500

mether gravatar image

Im having a mounting issue in fedora. Currently I am switching from Win8 to fedora. Im using fedora on a live disk to remove the files from my hard drive to put them on an external ( windows 8 has completly screwed it self up during updates and now wont boot.) When I try to access my Hard drive through fedora i get the error message:

Error mounting /dev/sda6 at /run/media/liveuser/DATA: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000" "/dev/sda6" "/run/media/liveuser/DATA"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0). Metadata kept in Windows cache, refused to mount. Failed to mount '/dev/sda6': Operation not permitted The NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting), or mount the volume read-only with the 'ro' mount option.

Can anyone help id really rather not loose all my data. I am a complete newb so pretend like your explaining it to your mother...

edit retag flag offensive close merge delete

Comments

http://ccm.net/faq/31793-windows-8-1-... will help in the future. read only is your best bet now, though.

randomuser gravatar imagerandomuser ( 2015-08-27 00:55:49 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
3

answered 2015-08-25 20:23:35 -0500

BRPocock gravatar image

Without access to Windows, your best bet is to mount with -o ro (read-only); eg,

 mkdir /mnt/win
 mount /dev/sda6 -o ro /mnt/win8
edit flag offensive delete link more

Comments

Would mounting as read only allow me to copy info from the drive?

SweaterNinja gravatar imageSweaterNinja ( 2015-08-25 20:57:17 -0500 )edit
1

It might, considering that the error message suggests exactly that. What it really needs is to be booted into Windows so that you can run scandisk on it, but from what you wrote, that's not possible right now.

sideburns gravatar imagesideburns ( 2015-08-25 21:11:31 -0500 )edit
2

answered 2015-08-25 22:27:52 -0500

geforce gravatar image

Have you tried?

su
ntfsfix /dev/sda6
edit flag offensive delete link more

Comments

hard drives are fried. thanks for the help

SweaterNinja gravatar imageSweaterNinja ( 2015-08-26 15:54:20 -0500 )edit
1

answered 2015-08-27 14:20:20 -0500

Navalona gravatar image

The definitive solution for this problem is to disable fast start up from windows 8.x/10

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-08-25 19:56:40 -0500

Seen: 123 times

Last updated: Aug 25 '15