Ask Your Question
2

Fedora takes a long time to load

asked 2015-09-09 12:47:10 -0600

jbrines gravatar image

updated 2015-09-09 16:59:08 -0600

I am on Fedora 22 but had the same issue on Fedora 21.

When I run I systemd-analyze blame get the following results.

[root@brines-acer ~] # systemd-analyze blame
5min 29.593s plymouth-quit-wait.service
1min 16.117s couchpotato.service
     54.574s mariadb.service
     50.315s dnf-makecache.service
     42.508s httpd.service
     27.717s cups.service
     19.356s dev-mapper-fedora\x2droot.device
     15.920s libvirtd.service
     15.566s systemd-udev-settle.service
     15.441s teamviewerd.service
     13.178s nmb.service
     11.669s systemd-journal-flush.service
     11.328s accounts-daemon.service
     10.682s smb.service
     10.035s colord.service
      9.903s NetworkManager-wait-online.service
      9.365s ddclient.service
      7.875s user@1000.service
      5.884s ModemManager.service
      5.229s mnt-TV\x20shows.mount
      4.994s systemd-journald.service
      4.620s chronyd.service
      4.537s netcf-transaction.service
      4.494s avahi-daemon.service
      4.382s rtkit-daemon.service
      4.382s mcelog.service
      4.339s systemd-udevd.service
      4.289s gdm.service
      4.283s lvm2-monitor.service
      4.258s systemd-logind.service
      4.166s gssproxy.service
      3.884s abrtd.service
      3.675s proc-fs-nfsd.mount
      3.526s packagekit.service
      3.290s mnt-Films1.mount

Ran systemd-analyze critical-chain and got the following

graphical.target @6min 11.781s
multi-user.target @6min 11.779s
couchpotato.service @41.349s +1min 16.117s
network.target @41.347s
NetworkManager.service @28.435s +2.998s
netcf-transaction.service @23.786s +4.537s
basic.target @23.742s
sockets.target @23.739s
iscsid.socket @23.737s
sysinit.target @23.722s
systemd-update-utmp.service @23.670s +48ms
auditd.service @23.515s +151ms 
systemd-tmpfiles-setup.service @22.451s +1.059s
fedora-import-state.service @22.217s +230ms
local-fs.target @22.182s
run-user-1000.mount @1min 418ms
local-fs-pre.target @7.383s
systemd-tmpfiles-setup-dev.service @5.387s +1.995s
kmod-static-nodes.service @4.722s +316ms
system.slice
slice
edit retag flag offensive close merge delete

Comments

2

Will recomend you to look at journal log size look at https://wiki.archlinux.org/index.php/...

aeperezt gravatar imageaeperezt ( 2015-09-09 13:35:07 -0600 )edit
2

The obvious suspect, of course, is couchpotato, but everything that takes more than 10 seconds is a possible issue. Try running systemd-analyze critical-chain to see if there's any one service that's acting as a bottleneck. Don't use your only answer to post the results; add it as an edit to the question.

sideburns gravatar imagesideburns ( 2015-09-09 13:48:33 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2015-09-09 18:11:01 -0600

sideburns gravatar image

This earlier question suggests that running systemctl mask plymouth-quit-wait.service as root will keep that unneeded service from running at boot, and considering that it takes 5 min 29 sec to "complete," that may be enough to get your boot time back to what it should be.

edit flag offensive delete link more
1

answered 2015-11-18 03:18:26 -0600

jbrines gravatar image

I fixed the issue by changing from GDM to LXDM and what a difference it made to me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-09-09 12:47:10 -0600

Seen: 480 times

Last updated: Nov 18 '15