Ask Your Question
2

journalctl is not logging anything

asked 2015-09-12 15:45:20 -0500

E0x gravatar image

hello,

i was trying check so Xorg log but when i check journalctl running it without argument ( to see all logs ) i get nothing, this the output i get for check Xorg file and without argument: [root@BlueMain xorg.conf.d]# journalctl -b _COMM=gdm-x-session No journal files were found. -- No entries --

[root@BlueMain xorg.conf.d]# journalctl No journal files were found. -- No entries --

any idea what is happening ?

thanks

edit retag flag offensive close merge delete

Comments

1

Can you edit with the output of systemctl status systemd-journald -l please?

randomuser gravatar imagerandomuser ( 2015-09-13 02:22:03 -0500 )edit

I am having the same issue. The output of systemctl status systemd-journald -l is as follows. โ— systemd-journald.service - Journal Service Loaded: loaded (/usr/lib/systemd/system/systemd-journald.service; static; ven Active: active (running) since Sat 2017-09-23 08:30:27 EDT; 17min ago Docs: man:systemd-journald.service(8) man:journald.conf(5) Main PID: 411 (systemd-journal) Status: "Processing requests..." Tasks: 1 (limit: 4915) CGroup: /system.slice/systemd-journald.service โ””โ”€411 /usr/lib/systemd/systemd-journald

wfmakowski gravatar imagewfmakowski ( 2017-09-23 07:53:41 -0500 )edit

Did you set Storage=none in /etc/systemd/journald.conf or in a file in /etc/systemd/journald.conf.d?

thomaswood gravatar imagethomaswood ( 2017-09-23 09:46:02 -0500 )edit

The journal was logging other information, just not anything from X. Xorg wasn't logging because the Wayland display server is enabled by default. Disabling it in /etc/gdm/custom.conf produced the logs and allowed my settings in xorg.conf to be recognized. If you are interested in learning more, the website for Wayland is https://wayland.freedesktop.org/ .

wfmakowski gravatar imagewfmakowski ( 2017-09-23 17:06:51 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-09-23 09:33:08 -0500

updated 2017-09-23 22:21:59 -0500

I know this is an old post, but after some additional surfing I was able to find an answer to this problem. The setting WaylandEnable=false was commented out in /etc/gdm/custom.conf. Making WaylandEnable=false forces it to use Xorg. Doing so also brought back log entries and made it use my settings in /etc/X11/xorg.conf. Here is what /etc/gdm/custom.conf looks like after the change.

[daemon]
# Uncoment the line below to force the login screen to use Xorg
WaylandEnable=false
edit flag offensive delete link more
0

answered 2017-09-23 09:36:31 -0500

you should check if /var/log is writeable when mounted as tmpfs. Also check the output of

mount

for mount flags that are set by default. For example it might be the case that for some reason your /var/log gets mounted read only. It's mounted as rw, I suppose from mount output: /var/log on /var/log type tmpfs (rw,nosuid,nodev,relatime) also

drwxr-xr-x 3 root root 140 Feb 12 07:46 log

edit flag offensive delete link more

Comments

Interesting thought, but /var/log is not mounted as tmpfs. It is part of the root filesystem and has the drwxrw-xr-x permissions you mentioned.

wfmakowski gravatar imagewfmakowski ( 2017-09-23 17:00:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-09-12 15:45:20 -0500

Seen: 2,650 times

Last updated: Sep 23 '17