Ask Your Question
1

Fedora 16 USB HDD permission

asked 2012-01-24 13:12:02 -0500

moti gravatar image

updated 2014-09-28 23:58:09 -0500

mether gravatar image

Hi,

I've just installed Fedora 16 after having FC11 for 3 years or so. What I noticed is that my USB media is connected and accessible, but it's impossible to change permissions (using FAT32 and NTFS volumes) and it is given 'rw' only for the owner, so it is impossible to execute linux applications on that volume or scripts.

I would really appreciate your help. Reading through the internet for the last 5 hours didn't yield much and the user interface tools don't match.

Thanks, Moti.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-01-25 05:27:47 -0500

FranciscoD_ gravatar image

I'm guessing this is because the devices are mounted as noexec by default. Verify this by running mount in a terminal. For a temporary workaround, you can try changing the permissions on the folders by using chmod as root. I'll have to dig up how one can change default mount parameters for USB devices, probably using policy kit.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-01-24 13:12:02 -0500

Seen: 864 times

Last updated: Jan 25 '12