Ask Your Question
1

Your intltool is too old

asked 2015-10-06 15:34:07 -0500

thrashzone_ua gravatar image

Hi. I'm trying to install gnome-shell-extension-weather. I have cloned this https://github.com/Neroth/gnome-shell... and ran this

./autogen.sh && make local-install

. The process of installation started but soon I saw a message: "configure: error: Your intltool is too old. You need intltool 0.26 or later." I've downloaded intltool-0.51.0-1.fc22.noarch.rpm and installed it with command

rpm -ivh intltool-0.51.0-1.fc22.noarch.rpm

But I still have message, that my intltool is too old. Can anybody help me please?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
2

answered 2015-10-06 23:56:38 -0500

davidva gravatar image

updated 2015-10-07 00:21:25 -0500

Try it...

   0) cd ~ && git clone https://github.com/Neroth/gnome-shell-extension-weather.git
   1) cd gnome-shell-extension-weather
   2) sed -i 's|IT_PROG_INTLTOOL(0.26)|IT_PROG_INTLTOOL(0.51)|g' configure.ac
   3) sed -i 's|"3.16"|"3.16", "3.18"|g' data/metadata.json.in
   3) ./autogen.sh && make local-install
edit flag offensive delete link more

Comments

Thank you for help. I did nearly the same (just added my GNOME version via gedit) and now I have this extension.

thrashzone_ua gravatar imagethrashzone_ua ( 2015-10-07 12:19:07 -0500 )edit
2

answered 2015-10-07 00:59:32 -0500

skytux gravatar image

First of all, you should not download RPM packages from the internet and install them with rpm command, unless you really know what you are doing.

In order to install intltool (or any other package in Fedora), you only need to issue the following command:

$ sudo dnf install intltool

With respect to the extension you are interested in, I recommend you to install OpenWeather, which was recently added to Fedora repositories:

$ sudo dnf install gnome-shell-extension-openweather

HTH,

Germán.

edit flag offensive delete link more

Comments

Thank you for your attention and help.

thrashzone_ua gravatar imagethrashzone_ua ( 2015-10-07 12:21:47 -0500 )edit
2

answered 2015-10-06 17:07:18 -0500

florian gravatar image

updated 2015-10-06 17:08:31 -0500

If you want to have it easy, you can go here, and click on ON. That will enable the OpenWeather extension for Gnome.

This is not the exact same thing like Weather, another extension which is currently not supported out-of-the-box in Gnome 3.16 (Fedora22) . Nevertheless, you can get to work by adjusting the corresponding .json file. For more info, see this Q and the accepted A. Little tweak will make it work but I personally prefer OpenWeather anyways.

Have fun.

edit flag offensive delete link more

Comments

Thank you for your attention and help.

thrashzone_ua gravatar imagethrashzone_ua ( 2015-10-07 12:28:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-06 15:34:07 -0500

Seen: 5,451 times

Last updated: Oct 07 '15