GDM asks for root password on shutdown/restart

asked 2015-10-22 15:57:48 -0500

becks21 gravatar image

updated 2015-11-04 12:24:59 -0500

Hi there,

since I upgraded from Fedora 21 -> 22 I can no longer shutdown/restart from the GDM login screen without providing the root password.

Can anyone tell me why that is and how I could correct that, so that I can shutdown/restart from GDM login screen without needing to provide the root password ?

Thx

Edit:

Output "gsettings list-recursively org.gnome.login-screen"

org.gnome.login-screen fallback-logo ''
org.gnome.login-screen disable-user-list false
org.gnome.login-screen allowed-failures 3
org.gnome.login-screen enable-smartcard-authentication false                                                                                
org.gnome.login-screen banner-message-enable false                                                                                          
org.gnome.login-screen enable-password-authentication true
org.gnome.login-screen disable-restart-buttons false
org.gnome.login-screen logo '/usr/share/pixmaps/fedora-gdm-logo.png'
org.gnome.login-screen enable-fingerprint-authentication true
org.gnome.login-screen banner-message-text ''

visudo shows for the "wheel" group:

## Allows people in group wheel to run all commands
%wheel  ALL=(ALL)       ALL

## Same thing without a password
# %wheel        ALL=(ALL)       NOPASSWD: ALL
edit retag flag offensive close merge delete

Comments

Is your regular user in the wheel group? What does it say in your sudoers file, i.e. visudo?

ILMostro gravatar imageILMostro ( 2015-10-23 06:16:26 -0500 )edit

What's the output when you execute gsettings list-recursively org.gnome.login-screen?

ILMostro gravatar imageILMostro ( 2015-10-23 06:26:00 -0500 )edit

So I'm assuming your user is in the wheel group. Try changing the line to %wheel ALL=(ALL) ALL:ALL

ILMostro gravatar imageILMostro ( 2015-11-10 22:36:19 -0500 )edit