Ask Your Question
1

xinput settings lost after reboot

asked 2015-10-24 08:14:35 -0500

Domenico gravatar image

Hi All,

I just installed the Fedora 22 on my laptop and I discovered that my mouse (external and wireless) was too slow. So, after some research I have identified its ID through the xinput command and reset the property by specifying in the terminal the following command line:

xinput --set-prop 11 148 30 0 0 0 30 0 0 0 1

where 11 is the id of my mouse 148 is the idenfifier of the Coordinate Transformation Matrix and the remaining number represent this matrix itself.

The thing is that by rebooting the machine the xinput setting go back to the original values and therefore the Coordinate Transformation Matrix looks like 1 0 0 0 1 0 0 0 1. Could you suggest a manner to keep the desired setting to my customized and desired value, rather that repeat the same command everytime?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-10-24 12:58:16 -0500

sideburns gravatar image

Welcome to ask.fedora. That's a good question, and I can see that you've done some research on this. I don't know what the underlying cause of this is, but I do know a way to work around it: create a shell script containing that command, make it executable and call it from /etc/rc.d/rc.local so that it runs at the end of every boot. You may also want to run systemctl enable rc-local.service as root to make sure the service is working properly. (It's supposed to activate on its own if rc.local exists, but it can't hurt to make sure.)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-10-24 08:14:35 -0500

Seen: 220 times

Last updated: Oct 24 '15