Ask Your Question
1

when does support for fedora 21 expire?

asked 2015-11-05 06:19:25 -0500

clh333 gravatar image

I installed Fedora Workstation 21 on two machines about a year ago. I have been updating packages weekly but did not realize until now that the current release is Fedora 23. Since I have never been through the (Fedora) update process before it looks a little daunting, prompting me to ask: How long do I have before support for Fedora 21 expires? And do I need to update to 22 before updating to 23?

Thanks for your reply. Charles Hudson clh333

edit retag flag offensive close merge delete

Comments

http://fedoramagazine.org/upgrading-f... and https://fedoraproject.org/wiki/DNF_sy... ... They changed the methods used to upgrade, so I'm not 100% sure, but I suspect you'd need either a clean install, or you'd need to update to 22 and then 23 . In either case make sure you create good backups.

spollei gravatar imagespollei ( 2015-11-05 09:36:18 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2015-11-05 08:23:23 -0500

aeperezt gravatar image

Fedora 21 end of live is set to one month after Fedora 23, is released, therefore Dic 4 of 2105. Following Fedora Release life cicle doc. https://fedoraproject.org/wiki/Fedora...

edit flag offensive delete link more
1

answered 2015-11-08 11:01:40 -0500

clh333 gravatar image

Thank you for your responses. I was successful with both machines in upgrading from 21 to 22. With one machine, a KDE desktop "spin", I was also successful upgrading to Fedora 23.

The other machine presented some problems with the upgrade to 23. I made sure I had updated all software, and followed the procedure outlined at http://fedoramagazine.org/upgrading-f... . From a terminal window, elevated to root, I got as far as "install dnf-plugin-system-upgrade". However, when I issued the next command, "dnf system-upgrade download --releasever=23 --best", I received an error message stating: "rubygem-celluloid-0.15.2-2 requires rubygem(timers)1.2. Try to add --allowerasing."

After a check of installed and available packages I determined that while I had rubygem-celluloid, I did not have rubygem(timers), nor was there such a package available for installation. I did have rubygem-timers 1.1.0-3 but since that wasn't specified, I added "--allowerasing" to the command.

Download proceeded, but issued a few warnings about packages that were unavailable from the mirror server. I rebooted but the upgrade did not start automatically. Again from a terminal I issued the command "dnf system-upgrade reboot", in response to which I was informed that the system was not ready for upgrade.

Not sure what to do next. clh333

edit flag offensive delete link more

Comments

1

@clh333, because this site is set up in a question and answer format, you only get one answer per question, and the answers are not especially ordered chronologically. It is not well suited to a forum-type discussion. If you have further questions, you should consider whether updating your original question or asking a new question is most appropriate.

randomuser gravatar imagerandomuser ( 2015-11-08 11:27:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-11-05 06:19:25 -0500

Seen: 119 times

Last updated: Nov 08 '15