Ask Your Question
0

xorg.conf is ignored

asked 2015-11-06 05:41:26 -0600

mithrial gravatar image

I run Fedora 23 64bit with proprietry Nvidia Drivers 352.55. For this, I downgraded xserver to the version from Fedora 22 xorg-x11-server-Xorg-1.17.3-1.fc22.x86_64. The nvidia module is loaded correctly, both my monitors are working fine, also CUDA 7.5 works as intended.

My problem is the xorg.conf.d/20-nvidia.conf file. The primary monitor supports 120Hz, the second 60Hz. When using nvidia-settings I can set the resolutions to 1920x1080 with 120Hz and 1920x1200 with 60Hz. Clicking apply applies the settings correctly. I can save the settings to a config file which I put to /etc/X11/xorg.conf.d/20-nvidia.conf. It has the following content:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 570"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DVI-I-2: 1920x1080_120 +0+0, DVI-I-3: 1920x1200_60 +1920+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

There is no /etc/X11/xorg.conf files, but an additional file /etc/X11/xorg.conf.d/00-keyboard.conf:

# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "de"
        Option "XkbModel" "pc105"
EndSection

So far so good, but when I boot the system, the settings are not applied. Everytime I have to open nvidia-settings and manually assign the resolutions and Hertz values.

What should I do, so that the values are used?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-02-07 21:20:06 -0600

ed209 gravatar image

Why you are running F23 with a downgraded X? F23 supports nvidia proprietary driver just fine. Add rpmfusion repository and you're fine, without all those useless Frankenstein maneuvres.

edit flag offensive delete link more
0

answered 2016-02-04 04:23:52 -0600

There should be a "Save to X Configuration File" button. image description

edit flag offensive delete link more

Comments

Thanks for the image, I clicked that button and wrote the file to a custom location because a normal user cannot write to /etc/*. Then, I manually merged the new file with the config file. In the question is the output of the tool.

mithrial gravatar imagemithrial ( 2016-02-04 05:02:24 -0600 )edit

Did you copy the xorg.conf file to /etc/X11/xorg.conf as root? Did it solve your problem?

thomaswood gravatar imagethomaswood ( 2016-02-04 05:16:35 -0600 )edit

I used vim as root and copied over the entries. The result is seen in the question. It did not solve the problem, that's why I asked the question in the first place. I will confirm later, maybe a recent update solved it.

mithrial gravatar imagemithrial ( 2016-02-04 06:12:16 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-06 05:41:26 -0600

Seen: 1,530 times

Last updated: Feb 04 '16