Ask Your Question
0

Fedora 23 + nvidia = gnome-shell mouse not working

asked 2015-11-10 06:14:57 -0500

Giulio_A gravatar image

updated 2015-11-10 20:43:05 -0500

mether gravatar image

Hi all. Ask your help for this very annoying bug.

Upgraded Fedora from 22 to 23.

Downgraded xorg from 1.18 to 1.17 F22, because nvidia driver does not like xorg 1.18 as it is still RC.

Rebuilded nvidia kernel driver for GEForce 6 and Linux kernel 2.4.5-300 F23 with akmods and xorg 1.17.

Now gnome 3.18 starts in F23 with this latest kernel, but mouse is not working in gnome-shell. Can't activate calendar, or other icons in top panel. Can't start apps with the mouse from apps bar. Can't switch workspaces. Can't give focus to an app from the app list showed by windows key. I have to use only keyboard, and reboot through another terminal.

Only upper left angle in top panel responds to mouse pointer.

Disabled all gnome extensions - problem persists.

Started Gnome with root user - problem persists.

Moreover, any application main bar does not respond to mouse click. Can't close application, or maximize it through button, or move it. Left or right mouse button is not working.

But the mouse _is_ working inside applications. For example, I can use Firefox or Thunderbird without problem. Only application main bar is completely not responding to mouse clicks.

Any idea or help is greatly appreciated.

Thank you.

edit retag flag offensive close merge delete

Comments

I have no idea why Fedora 23 has been officially released even before Xorg 1.18 was released and related Nvidia drivers ready.

I now use Nvidia beta driver and it's not 100% stable. If I had known all these issues, I would have waited for 3~4 weeks to try Fedora 23.

If you can, stick to Fedora 22 until all the issues ironed out for Nvidia video cards.

kimbn gravatar imagekimbn ( 2015-11-10 08:21:03 -0500 )edit

For what it's worth, you aren't the only one.

To me, it appears to be a Gnome specific problem.

As a temporary measure, I've switched to using WindowMaker. The mouse works just fine in that window manager. A lot of Gnome applications will run in it too (though maybe not as well).

Additionally, I have no idea how to go about capturing any diagnostic information about this. Anyone have ideas?

UPDATE: I switched my driver from 304xx to 340xx and that seems to have fixed my mouse issue.

ephae gravatar imageephae ( 2015-11-10 08:23:09 -0500 )edit
1

@kimbn - Add my personal suggestion - Fedora + Nvidia users should all wait new official Nvidia driver release before upgrading to Fedora 23.

Giulio_A gravatar imageGiulio_A ( 2015-11-10 09:36:10 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-11-10 10:53:09 -0500

Giulio_A gravatar image

My temporary solution for this issue.

  1. Downgrade Xorg to release 1.17 ( F22 ) with command dnf --allowerasing --releasever=22 downgrade xorg-x11-server-Xorg
  2. Install Negativo17 Nvidia drivers instead of RPMFusion Nvidia driver - follow instruction Here
  3. Reboot
  4. Fedora 23 + Gnome 3.18 + Nvidia = OK. Gnome-shell now fully listens and responds to mouse events.

I suggest to use this workaround until the situation will be normalized and aligned again among Xorg, Nvidia drivers and RPMFusion.

edit flag offensive delete link more

Comments

Glad you fond a solution although it sounds messy.

bodhi.zazen gravatar imagebodhi.zazen ( 2015-11-10 11:28:07 -0500 )edit
0

answered 2015-11-10 06:56:15 -0500

You would have to file a bug report. Fedora would reject it as you are using the nvidia driver. Nvidia will reject it as you are using wayland. If you are not using wayland, be sure to tell Nvidia as well as the version of X . https://devtalk.nvidia.com/default/to...

edit flag offensive delete link more

Comments

Just submit this question to Nvidia forum. The first answer is: change desktop environment :-). Quote: "this is obviously a Gnome bug".

link text

I hope Nvidia does not say "it's a Gnome bug", and Gnome, in turn, does not say "it's a Nvidia bug".

link text

Giulio_A gravatar imageGiulio_A ( 2015-11-10 09:41:40 -0500 )edit

If it works in other DE, then one can make an argument that it is a gnome bug. Fedora will not accept a bug report if you are using the nvidia driver. You can try upstream (gnome) , I am not sure what they would do. From https://fedoraproject.org/wiki/How_to... "If you are using a driver with the name nvidia (not nv or nouveau) or fglrx, you are using a proprietary third-party video driver (respectively, the proprietary drivers provided by NVIDIA and AMD/ATI). Please do not report any bugs in these drivers to Fedora, as we do not provide or support these drivers. "

bodhi.zazen gravatar imagebodhi.zazen ( 2015-11-10 10:03:41 -0500 )edit

Gnome will not take bug reports against Xorg - https://wiki.gnome.org/Bugsquad/Triag...

bodhi.zazen gravatar imagebodhi.zazen ( 2015-11-10 10:06:26 -0500 )edit

It appears Xorg will direct you back to nvidia - http://www.x.org/wiki/NVIDIAProprieta...

bodhi.zazen gravatar imagebodhi.zazen ( 2015-11-10 10:10:42 -0500 )edit

So either use an alternate DE or use the open source drivers if you want open source support. If you use the nvidia driver, bug nvidia as their driver is closed source.

bodhi.zazen gravatar imagebodhi.zazen ( 2015-11-10 10:11:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-10 06:14:57 -0500

Seen: 5,709 times

Last updated: Nov 10 '15