Ask Your Question
2

grub is wrong [closed]

asked 2015-11-22 06:45:04 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I reinstall windows 8 and after this fedora 23 not loaded/ I had very much times run command 'grub2-install ....' with many different params and my last results is get message '/boot/efi is doesnt look like as UEFI partition'. After it I disable UEFI mode in BIOS and run next commands:

sudo mount /dev/sda8 /mnt
grub2-install --boot-directory=/mnt /dev/sda

However, I got new error message:

[liveuser@localhost ~]$ grub2-install: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.
> grub2-install: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
> grub2-install: error: will not proceed with blocklists.

please, help me!!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by aqw
close date 2015-11-24 03:09:34.099472

Comments

This addresses a very specific configuration issue in a way that isn't quite following best practices, and the circumstances aren't well developed in the question. I'm glad you got it working, but caution, readers, the solution is not portable to your system.

randomuser gravatar imagerandomuser ( 2015-11-24 08:40:12 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-11-22 09:51:12 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

  • I have solution for my problem:
  • Before: enable EFI mode in BIOS and run fedora system from liveCD
  • First, run command "parted /dev/sda set 1 bios_grub on", where sda - partition, where location your OS - it's command fix problem "this partition label contains no BIOS Boot Partition"
  • Second, run command "sudo mount /dev/sda8 /mnt" , where sda8 - fedora's boot disk
  • Third, run command "sudo mount /dev/sda2 /mnt/efi" , where sda2 - EFI disk
  • And after it, run next command "grub2-install --boot-directory=/mnt --efi-directory=/mnt/efi /dev/sda"
  • Also, please, check uuid of EFI disk and uuid in your file /etc/fstab (if are you get error message after loading fedora system)
  • How to get uuid of partition: blkid /dev/sda2
  • How to simple check uuid of devices in /etc/fstab: mount -a
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-11-22 06:45:04 -0500

Seen: 625 times

Last updated: Nov 24 '15