Ask Your Question
0

[Fedora 23] Installing KDE Plasma as a second Desktop Environment! [bug]

asked 2015-11-22 16:32:59 -0500

giumbai gravatar image

updated 2015-11-22 16:38:01 -0500

Hi!

I have Fedora 23 installed on a Lenovo E540 with the default Gnome 3 Desktop Environment. I was thinking of trying multiple Desktop Environments, so that I might see what are thee new breakthroughs. Basically I'm using Gnome for a long time.

What better way to try a new interface then just installing it along Gnome 3? So I've installed KDE using dnf groupinstall "KDE Plasma Workspaces" I was very surprised to find out that after the reboot KDE wold not work ...

What happened is that when I chose to log into KDE my screens changes and the Desktop Background appears the just in a few second I'm back to the log in screen. No matter how many restarts or how many times i try the result is the same.

  • Is the first time I tried to have multiple Desktop Environments on Fedora, is this something that happens often or is it because of fedora 23?
  • And why wold this happen, all seems very straightforwards.
  • Should I make a bug report and what should I write in it?
  • What is your experience in having multiple desktop environments on Fedora?
edit retag flag offensive close merge delete

Comments

1

I have multiple DE in Fedora 23 including KDE, Gnome, lxqt, and fluxbox and they all work for me. Check your logs and .xsession-errors. KDE is sometimes buggy with my mutimonitors, so you can try mv .kde .kde.bak and log in again (corrupte kde configuration ?).

bodhi.zazen gravatar imagebodhi.zazen ( 2015-11-23 08:44:11 -0500 )edit

your problem sounds like the Fedora 23 gdm bug. gdm does not work for some Graphics card. In my case, I've ditched gdm and I use kdm instead. Install kdm. Disable gdm and enable kdm with systemctl command and reboot. I guarantee that kdm will work. Otherwise, you wait 1 ~ 2 weeks till the gdm bug fixed.

kimbn gravatar imagekimbn ( 2015-11-23 13:13:30 -0500 )edit

@kimbn - First, sddm is now default with kde in Fedora - see https://fedoraproject.org/wiki/Change... . Second, the OP is getting a graphical login.

bodhi.zazen gravatar imagebodhi.zazen ( 2015-11-23 13:43:09 -0500 )edit

Hello. This has happened to me multiple times on openSuSe Tumbleweed. The only way for me to log in was to press Ctrl + Alt + Backspace, Backspace (2 times backspace) to restart the session. After that I could login. But I had to do this at every login when using KDE Plasma

Darius gravatar imageDarius ( 2017-03-25 13:45:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-12-12 04:04:42 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I had the similar problem.

In the ~/.xsession-errors file I found:

klauncher: error while loading shared libraries: *libQt5Svg.so.5*: cannot open shared object file: No such file or directory 
kdeinit5: Communication error with launcher. Exiting!

Identify the missing package :

dnf provides '*/libQt5Svg.so.5'

And then install the package:

dnf install qt5-qtsvg

And now it works for me.

edit flag offensive delete link more

Comments

Thank you for posting this, I added some information. Although the behavior was similar, we do not have sufficient information from the OP to know if this the same or a similar problem. I would suggest you file a bug report as , IMHO, qt5-qtsvg should have been pulled as a dependency

bodhi.zazen gravatar imagebodhi.zazen ( 2015-12-13 08:00:48 -0500 )edit
1

Thanks for the corrections. I filed a bug

Maitreya gravatar imageMaitreya ( 2015-12-13 15:27:16 -0500 )edit

New 3rd party rpm (rstudio) added to known bug.

Maitreya gravatar imageMaitreya ( 2015-12-14 10:35:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-11-22 16:32:59 -0500

Seen: 11,955 times

Last updated: Dec 13 '15