Screen 30-bit colour depth

asked 2015-11-24 05:22:26 -0500

rt gravatar image

updated 2015-11-24 08:30:47 -0500

If I alter /etc/X11/xorg.conf to:

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 30
SubSection "Display"
Depth 30
EndSubSection
EndSection

the result is that clicking anything with the mouse (in Gnome) produces no result. The keyboard works correctly, so I can open a terminal etc, and start programs that way ā€“ but with no use of the mouse in them.

Both my graphics card and screen support 30-bit colour depth (10-bits per channel per pixel).

I see others are having similar problems with other Linux distros although some have better results with some applications than others. nVidia states that this is to be expected: http://nvidia.custhelp.com/app/answer...

If I were to know where the problem lies with the mouse, I might be able to submit a bug report.

edit retag flag offensive close merge delete

Comments

Same thing happens with LXDE. Yes, I am using DisplayPort.

rt gravatar imagert ( 2015-11-24 08:08:42 -0500 )edit

If you are having a problem with the nvidia driver, file a bug with nvidia. If not, identify your hardware and the driver you are using.

bodhi.zazen gravatar imagebodhi.zazen ( 2015-11-24 10:15:28 -0500 )edit

But all works fine except Java (currently) on KDE Plasma.

rt gravatar imagert ( 2015-11-30 15:21:00 -0500 )edit

Was this issue ever resolved? Iā€™m on 27 and driver 390.25 and have exactly the same issue with a Quadro P4000.

aidanr gravatar imageaidanr ( 2018-02-10 15:53:44 -0500 )edit