Ask Your Question
2

Fedora 23 Enterprise WiFi network connection issue

asked 2015-11-30 07:59:47 -0500

barashe gravatar image

updated 2016-04-13 02:24:28 -0500

geforce gravatar image

I recently upgraded Fedora21 to Fedora23.

Ever since, I cant connect to my university's Wi-Fi. While trying to connect, the network manager keeps asking me to type in the password.

from /var/log/wpa_supplicant.log:

wlp1s0: Trying to associate with 00:19:07:37:6b:46 (SSID='BGU-WPA' freq=2412 MHz)
wlp1s0: Associated with 00:19:07:37:6b:46
wlp1s0: CTRL-EVENT-EAP-STARTED EAP authentication started
wlp1s0: CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=IL
wlp1s0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=25
wlp1s0: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 25 (PEAP) selected
wlp1s0: CTRL-EVENT-EAP-FAILURE EAP authentication failed
wlp1s0: Authentication with 00:19:07:37:6b:46 timed out.
wlp1s0: CTRL-EVENT-DISCONNECTED bssid=00:19:07:37:6b:46 reason=3 locally_generated=1
wlp1s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="BGU-WPA" auth_failures=1 duration=10 reason=AUTH_FAILED
wlp1s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="BGU-WPA" auth_failures=2 duration=32 reason=CONN_FAILED
wlp1s0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
wlp1s0: CTRL-EVENT-REGDOM-CHANGE init=USER type=COUNTRY alpha2=IL

The connection details are:

WPA & WPA2 Enterprise / PEAP / no CA certificate / automatic peap version / MSCHAPv2

Anyone? I've been trying to solve this for a long time now.. And I really don't want to change to Ubuntu just because of this..

edit retag flag offensive close merge delete

Comments

1

I read somewhere that this happens because Fedora23 (and 22) uses TSL 1.2 security protocol, and many corporate servers don't. Any one knows how to disable TSL 1.2 in Fedora?

barashe gravatar imagebarashe ( 2015-12-03 04:48:48 -0500 )edit

You probably mean TLS 1.2, right? Disabling it would be pretty bad since it is the only encryption not yet broken. Are you missing a CA certificate?

genodeftest gravatar imagegenodeftest ( 2016-04-12 14:27:37 -0500 )edit

No, the connection does not require one.

barashe gravatar imagebarashe ( 2016-04-14 13:08:42 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2016-04-13 01:35:04 -0500

genodeftest gravatar image

Please have a look at this question and its answers.

edit flag offensive delete link more

Comments

2

But don't just disable SELinux to fix the problem.

florian gravatar imageflorian ( 2016-04-13 09:33:33 -0500 )edit
2

answered 2016-04-13 08:49:37 -0500

aderocha1a gravatar image

Please, check here if you have same problem that I had:

   https://ask.fedoraproject.org/en/question/86313/fedora-23-does-not-connect-to-wlan-wpa_eap/
edit flag offensive delete link more

Comments

1

But don't just disable SELinux to fix the problem (even though it may fix it)!

florian gravatar imageflorian ( 2016-04-13 09:32:53 -0500 )edit
0

answered 2016-04-17 06:30:13 -0500

barashe gravatar image

Thank you all! My issue is now solved :)

To aid others, this is the custom wpa_supplicant.conf I've created:

ctrl_interface=/var/run/wpa_supplicant
network={
ssid="BGU-WPA"
key_mgmt=WPA-EAP
eap=PEAP
identity="my_username"
password="my_password"
phase1="peaplabel=auto tls_disable_tlsv1_2=1"
phase2="auth=MSCHAPV2"
}

I then turned off the network manager and ran the commands:

rfkill unblock wifi
wpa_supplicant -B -i my_interface -D wext -c /etc/wpa_supplicant/custom_wpa_supplicant.conf
dhclient

Since I didn't want to include a full password in the file (it's a university password, can be used for much more than logging to the Wi-Fi network) I hashed it using

smbencrypt my_password

and instead of

password="my_password"

in the conf file I added:

password=hash:my_hashed_password
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-30 07:58:23 -0500

Seen: 5,200 times

Last updated: Apr 17 '16