Ask Your Question
5

How do I get Num Lock to be turned on at boot time for LXDE Spin?

asked 2011-11-12 19:07:27 -0500

Pluto is a Planet gravatar image

updated 2011-11-15 19:16:05 -0500

I type in numbers in for my username password, so it irks me that I have to press Num Lock every time I start up Fedora. So I want num lock to be enabled when I boot Fedora, and to do this, I'm guessing I'll need to edit the configuration file that controls what happens when Fedora starts up.

Can anyone help me out? I'm using LXDE Spin. Thanks!

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
6

answered 2011-11-13 06:58:06 -0500

hhlp gravatar image

updated 2011-11-13 06:58:54 -0500

For some reason numlock is reset every time Gnome 3 shuts down returning to its default state (off).

Using a program called numlockx there are 2 ways we can do this, when you log in which affects just your account or at startup affecting everyone.

First download numlockx from the repos. For Fedora:

sudo yum install numlockx

1. Turn Numlock on at Login

Launch the hidden application to edit the applications that launch on login: gnome-session-properties

Add a new entry

Name: Numlockx Command: numlockx on Comment: Turns on numlock

2. Turn Numlock on at Startup

As a superuser edit the file /etc/X11/xinit/xinitrc

sudo nano /etc/X11/xinit/xinitrc

At the beginning of the file add the following line

/usr/bin/numlockx on

Numlock should now have the behaviour that you want!

edit flag offensive delete link more

Comments

You can say thanks by selecting the answer as the right one!

mether gravatar imagemether ( 2011-11-13 19:43:38 -0500 )edit

yes it matter this work in gnome i'm not sure this work in lxde could you update your post and specify LXDE Spin?..

hhlp gravatar imagehhlp ( 2011-11-15 06:46:38 -0500 )edit

do you have xorg-x11-xinit package installed on your system? If not, install it and try.

mether gravatar imagemether ( 2011-11-20 16:43:02 -0500 )edit

Install the session package too. can't hurt.

mether gravatar imagemether ( 2011-11-24 06:34:51 -0500 )edit

Installed numlockx, Disregarded step 1. Just add the line to your xinitrc and your numlock will be on next reboot. Works on F18 LXDE.

Incognito gravatar imageIncognito ( 2013-06-15 22:46:54 -0500 )edit
2

answered 2011-11-12 21:50:57 -0500

asto gravatar image
# sudo yum -y install numlockx
edit flag offensive delete link more
1

answered 2012-04-03 05:01:52 -0500

Inspired by a discussion for Ubuntu on the same subject, here is the way which works for me on Fedora 16 LXDE Spin with its default display manager LXDM:

As a superuser edit the file /etc/lxdm/lxdm.conf

sudo leafpad /etc/lxdm/lxdm.conf

Find the line

# numlock=0

uncomment it and make the value 1, result should be like this:

numlock=1

Save and exit.

On your next login Num Lock should be on, starting from the display manager.

edit flag offensive delete link more

Comments

I think this is the neat way to do it. Worked for me.

orcolat gravatar imageorcolat ( 2014-08-29 04:55:59 -0500 )edit

Worked great for me, thank you very much.

Feli gravatar imageFeli ( 2018-03-06 07:09:20 -0500 )edit
0

answered 2013-04-04 04:49:33 -0500

flebber gravatar image

There is also a gnome extension to manage your numlock and capslock keys.

see it here Lock Keys

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-11-12 19:07:27 -0500

Seen: 15,847 times

Last updated: Apr 04 '13