Ask Your Question
2

Why are there 2 sets of boost packages, boost and boost141?

asked 2012-05-08 18:14:21 -0500

HoboPrimate gravatar image

To compile electric sheep I need the boost development packages, but I see 2 versions of them, boost-devel and boost141-devel. Looking at their versions, boost is at version 1.4.8 and boost141 at version 1.4.1. Do I install the newer boost? And why are there 2 versions of these packages? I'm running Fedora 17.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2012-05-08 19:33:45 -0500

aatdark gravatar image

sounds like some packages depend on the older version.

Anyway: I looked at the configure.ac file of electric sheep: http://code.google.com/p/electricsheep/source/browse/trunk/client_generic/configure.ac

REQ_BOOST_VERSION=103900
AC_MSG_CHECKING(for libboost >= 1.39)

So both versions should be fine.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-08 18:14:21 -0500

Seen: 585 times

Last updated: May 08 '12