Ask Your Question
0

(F.23)[Server]Type one character two appear on the screen

asked 2015-12-27 20:45:14 -0500

Dwayne gravatar image

So, I thought for Poops and giggles, I would install Fedora Workstation GUI on my Fedora Server 23. Got it to work, ya! BUT, I cannot login. When I type one character, two appear in the login name, and password fields. And the mouse will not respond, though it did when I was installing the server, but on the GUI login screen, no go. Also, the screen refresh for the GUI responds quite slowly. I don't think it is the hardware, I have this on a current server, with two processors, with 4 cores each, and 32GB of memory each. Video is running off the Mobo.

In a related post, how do I get out of the GUI and go back to CL so I can start troubleshooting?

edit retag flag offensive close merge delete

Comments

Welcome to ask.fedora. To get to a CLI without rebooting, use CTRL-ALT-FN, where N is (at least on my computer) between 2 and 6, inclusive. (Using F1 brings you back to the GUI.) Once you're there, you can easily log in as root if needed, unlike in the GUI. If that works, there's probably something wrong with your display manager (gdm if you use Gnome) and if not, try a different keyboard. Good luck, and please keep us informed.

sideburns gravatar imagesideburns ( 2015-12-27 21:29:57 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-12-28 18:02:18 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Fixed!! So, I reinstalled Fedora, since I had nothing setup on it.

To get Gnome working on Fedora Server 23, this is what worked for me:

root# dnf -y group install "Fedora Workstation"

Then type this, once you've had an hour nap waiting for the installation

root# echo "exec /usr/bin/gnome-session" >> ~/.xinitrc

and finally, run it:

root# startx
edit flag offensive delete link more

Comments

That didn't work for me I am running 25 server but i have to log in on a new ttyl and run as root to be able to get the mouse and keyboard to function normally. any ideas on how to fix.

NoobLinux gravatar imageNoobLinux ( 2017-05-17 21:27:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-12-27 20:45:14 -0500

Seen: 227 times

Last updated: Dec 27 '15