Ask Your Question
0

Cannot "startx" after kernel upgrades

asked 2016-01-28 07:36:56 -0500

mpajoh gravatar image

All: After upgrade to the last two kernels 4.3.3-300 and 4.3.3-301, when I boot to these kernels, "startx" fails!! The third oldest kernel, 4.2.8-300, does not have this problem. I tried: Code:

Sudo akmods --kernels $(uname -r)

For both of the failed kernels. And the returned message says: Code:

Checking kmods exist for 4.3.3-300.fc23.x86_64 [ OK ] Building and installing ndiswrapper-kmod. [ FAILED ]

Here is Xorg.0.log.old:

[ 1708.421] X.Org X Server 1.18.0 Release Date: 2015-11-09 [ 1708.421] X Protocol Version 11, Revision 0 [ 1708.421] Build Operating System: 4.2.5-300.fc23.x86_64 [ 1708.421] Current Operating System: Linux localhost.localdomain 4.3.3-301.fc23.x86_64 #1 SMP Fri Jan 15 14:03:17 UTC 2016 x86_64 [ 1708.422] Kernel command line: BOOT_IMAGE=/vmlinuz-4.3.3-301.fc23.x86_64 root=UUID=65ea93d6-9f7c-4bc7-8fe5-a7e6a7a69c20 ro rd.md=0 rd.lvm=0 rd.dm=0 vconsole.FONT=True vconsole.keymap=us rd.luks=0 LANG=en_US.UTF-8 rhgb vga=794 quiet [ 1708.422] Build Date: 16 November 2015 10:08:25AM [ 1708.422] Build ID: xorg-x11-server 1.18.0-2.fc23 [ 1708.422] Current version of pixman: 0.33.6 [ 1708.422] Before reporting problems, check http://wiki.x.org to make sure that you have the latest version. [ 1708.422] Markers: (--) probed, ( ) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown. [ 1708.423] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jan 27 21:05:17 2016 [ 1708.485] (==) Using config file: "/etc/X11/xorg.conf" [ 1708.485] (==) Using config directory: "/etc/X11/xorg.conf.d" [ 1708.485] (==) Using system config directory "/usr/share/X11/xorg.conf.d" [ 1708.579] (==) No Layout section. Using the first Screen section. [ 1708.579] (==) No screen section available. Using defaults. [ 1708.579] () |-->Screen "Default Screen Section" (0) [ 1708.579] () | |-->Monitor "<default monitor="">" [ 1708.595] (==) No device specified for screen "Default Screen Section". Using the first device section listed. [ 1708.595] () | |-->Device "Videocard0" [ 1708.595] (==) No monitor specified for screen "Default Screen Section". Using a default monitor configuration. [ 1708.595] (==) Automatically adding devices [ 1708.595] (==) Automatically enabling devices [ 1708.595] (==) Automatically adding GPU devices [ 1708.595] (==) Max clients allowed: 256, resource mask: 0x1fffff [ 1708.595] (==) FontPath set to: catalogue:/etc/X11/fontpath.d, built-ins [ 1708.595] (**) ModulePath set to "/usr/lib64/nvidia-304xx/xorg,/usr/lib64/xorg/modules" [ 1708.595] (II) The server relies on udev to provide the list of input devices. If no devices become available, reconfigure udev or disable AutoAddDevices. [ 1708.595] (II) Loader magic: 0x81cde0 [ 1708.595] (II) Module ABI versions: [ 1708.595] X.Org ANSI C Emulation: 0.4 [ 1708.595] X.Org Video Driver: 20.0 [ 1708.595] X.Org XInput driver : 22.1 [ 1708.595] X.Org Server Extension : 9.0 [ 1708.597] (++) using VT number 1

[ 1708.599] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31 [ 1708.601] (--) PCI:*(0:5:0:0) 10de:0392 ... (more)

edit retag flag offensive close merge delete

Comments

Do you have any log files in /var/cache/akmods/nvidia-304xx which might shed some light on this?

bitwiseoperator gravatar imagebitwiseoperator ( 2016-01-28 09:14:16 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-01-30 15:43:23 -0500

becks21 gravatar image

updated 2016-01-30 15:44:32 -0500

boot your newly installed kernel to runlevel 3, then as root remove the akmod nvidia package with

dnf remove akmod-nvidia

reboot to runlevel 3 again, check if you can 'startx' (using VESA or, if still present, nouveau).

then you may try to reinstall akmod-nvidia package.

I have this issue from time to time and usually it solves it for me.

edit flag offensive delete link more
0

answered 2016-01-30 15:34:11 -0500

mpajoh gravatar image

Yes I do and the pertinent part is: . . . . Running transaction Installing : kmod-nvidia-304xx-4.3.3-303.fc23.x86_64-304.131-1.fc23.x8 1/1 depmod: WARNING: /lib/modules/4.3.3-303.fc23.x86_64/extra/nvidia-304xx/nvidia.ko needs unknown symbol mtrr_del depmod: WARNING: /lib/modules/4.3.3-303.fc23.x86_64/extra/nvidia-304xx/nvidia.ko needs unknown symbol mtrr_add Verifying : kmod-nvidia-304xx-4.3.3-303.fc23.x86_64-304.131-1.fc23.x8 1/1

Installed: kmod-nvidia-304xx-4.3.3-303.fc23.x86_64.x86_64 304.131-1.fc23

Complete! 2016/01/30 10:45:41 akmods: Successful.


Even then still has problems.

But this: dmesg|grep nvidia returns: [ 26.198240] nvidia: module license 'NVIDIA' taints kernel. [ 26.219657] nvidia: module verification failed: signature and/or required key missing - tainting kernel [ 26.220140] nvidia: Unknown symbol mtrr_del (err 0) [ 26.220257] nvidia: Unknown symbol mtrr_add (err 0) [ 105.814422] nvidia: Unknown symbol mtrr_del (err 0) [ 105.814568] nvidia: Unknown symbol mtrr_add (err 0)

In another forum someone said I have to wait for a new Kernel.

Thanks anyway.

edit flag offensive delete link more

Comments

It is possible that you must await a fix, but what Nvidia hardware are you using? It might be possible for you to use the kmod-nvidia-340xx driver which doesn't seem to be suffering from this problem.

bitwiseoperator gravatar imagebitwiseoperator ( 2016-02-04 09:37:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-28 07:36:56 -0500

Seen: 527 times

Last updated: Jan 30 '16