Ask Your Question
2

How to enable click middle button on touchpad in gnome 3

asked 2016-02-07 03:56:32 -0500

alsoijw gravatar image

updated 2016-02-07 20:47:52 -0500

mether gravatar image

In other operating systems I used one fingers click left button two fingers click right button and three fingers to click middle button. In #Fedora 23 I can use left and right click using touchpad but can't use middle click. I tried use synclient.

[alsoijw@localhost ~]$  synclient
Couldn't find synaptics properties. No synaptics driver loaded?
[alsoijw@localhost ~]$
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2016-02-07 17:50:04 -0500

whot gravatar image

updated 2016-02-09 18:15:51 -0500

Fedora 22 and later use the xorg-x11-drv-libinput driver by default which works differently to synaptics. synclient is a synaptics-specific property, that's why synclient doesn't work.

for most touchpads, libinput enables software buttons by default, see: https://wayland.freedesktop.org/libin...

If you want clickfinger enabled, you need to either set it in the xorg.conf (see man libinput, option ClickMethod), set it in GNOME (gsettings set org.gnome.desktop.peripherals.touchpad click-method 'fingers') or enable it at runtime with xinput set-prop "touchpad device name" "libinput Click Method Enabled" 0 1

Other desktop environments may have a toggle for it, I just don't know what those toggles are.

[edit 10/02: fix gsettings command,the right key is 'fingers']

edit flag offensive delete link more

Comments

There isn't option clickfinger in org.gnome.desktop.peripherals.touchpad click-method. There are fingers. If I select it, nothing change.

alsoijw gravatar imagealsoijw ( 2016-02-08 03:32:33 -0500 )edit

thanks, I've edited the answer to read 'fingers' now. Check with xinput list-props <device name=""> whether the Click Method property changes when you toggle that key. if not → GNOME bug, if it does → libinput bug

I'm also assuming that by "click" you mean "physically click the touchpad with N fingers down", not tapping. If three-finger tapping doesn't work that's a current kernel bug we're aware of but don' t have a fix for yet.

whot gravatar imagewhot ( 2016-02-09 18:18:42 -0500 )edit

I set 'fingers' using dconf. It don't work. What you say about "physically click the touchpad with N fingers down"? I don't understand this because I use translator. Forum on my native language was closed. I touch the touch pad with one finger, so touch pad emulates click left mouse button. When I touch the touch pad two fingers, so the touch pad emulates click right mouse button. But if I touch three fingers nothing done. If I touch and release the touch panel after that I touch but don't release and move fingers on touch pad it emulates as dragging while holding the button.

alsoijw gravatar imagealsoijw ( 2016-02-10 05:50:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-02-07 03:56:32 -0500

Seen: 3,601 times

Last updated: Feb 09 '16