Ask Your Question
0

Yum update fails after upgrade from F15 to F16 while doing a transaction check

asked 2011-12-10 00:35:53 -0500

vzades gravatar image

I have updated my fedora 15 to fedora 16 and now when i am updating my fedora 16 using command yum update i am getting transaction error . please help me .

ERROR with transaction check vs depsolve:
perl(HTML::Form) >= 1.00 is needed by perl-WWW-Mechanize-1.68-2.fc16.noarch
Please report this error in http://yum.baseurl.org/report
** Found 59 pre-existing rpmdb problem(s), 'yum check' output follows:
GConf2-gtk-2.32.3-1.fc15.i686 has missing requires of GConf2 = ('0', '2.32.3', '1.fc15')
ImageMagick-perl-6.6.5.10-19.fc15.i686 has missing requires of ImageMagick = ('0', '6.6.5.10', '19.fc15')
ImageMagick-perl-6.6.5.10-19.fc15.i686 has missing requires of perl(:MODULE_COMPAT_5.12.3)
device-mapper-multipath-0.4.9-15.fc15.i686 has missing requires of kpartx = ('0', '0.4.9', '15.fc15')
evolution-sharp-0.21.1-12.fc15.i686 has missing requires of libcamel-1.2.so.23
evolution-sharp-0.21.1-12.fc15.i686 has missing requires of libebook-1.2.so.10
evolution-sharp-0.21.1-12.fc15.i686 has missing requires of libecal-1.2.so.8
............
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-12-10 02:57:23 -0500

SoumyaC gravatar image

Please do a post upgrade cleanup. Find the details regarding how to do in the below link

Post Upgrade Cleanup

The problems you are facing due to existing rpmdb's should be gone and there shouldn't be any more transaction check errors.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-12-10 00:35:53 -0500

Seen: 1,732 times

Last updated: Dec 10 '11