Ask Your Question
2

VMware Workstation not launching on Fedora 23.

asked 2016-03-14 11:32:47 -0500

Hello! I have a problem.I have installed VMware Workstation 11 after a long time looking through articles. After I've managed to install it, I came across a huge problem, it won't even run. It won't even display any errors. I have tried VMware player that came with it but I have still the same problem on it :-(.

Can anyone kelp me?

RealPlayerCraft

edit retag flag offensive close merge delete

Comments

What do you need it for?

Why don't you try using Gnome Boxes, it's not only free (free as in freedom), it's also already pre-installed on your Fedora with Gnome, and it works out-of-the-box.

(And if you really need it because someone gave you a VMWare image that you want to boot, you can use their Player ver 12 from here

florian gravatar imageflorian ( 2016-03-14 12:46:18 -0500 )edit

Also, check out this one here: https://ask.fedoraproject.org/en/ques...

florian gravatar imageflorian ( 2016-03-14 19:52:08 -0500 )edit

@florian I have the player but it fails to launch

RealPlayerCraft gravatar imageRealPlayerCraft ( 2016-03-31 15:35:10 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2016-03-15 12:59:11 -0500

hhlp gravatar image

updated 2016-05-30 06:27:29 -0500

I point you maybe in the right direction, this is a know bug, I open a discussion in the vmware community, maybe this can help you, you can apply the solution, I only want to say I don't test it at all :

here are another post that a person follow and got some problem :

regards.,

Note :

sudo su -

Install required packages and force rebuild of VMWare modules:

dnf install kernel-headers kernel-devel gcc glibc-headers

First, find the version suffix of your GLIB library: On FC23:

$ ls -l /usr/lib64/libglib-2.0.so.0.*
-rwxr-xr-x. 1 root root 1290352 Oct 19 16:52 /usr/lib64/libglib-2.0.so.0.4600.1

On FC23 + updates (20151125):

$ ls -l /usr/lib64/libglib-2.0.so.0.*
-rwxr-xr-x. 1 root root 1290352 Nov  9 06:36 /usr/lib64/libglib-2.0.so.0.4600.2

Next, replace the vmware glib version with the fedora version found above, This expands to the following:

cd /usr/lib/vmware/lib
/bin/cp -afv /usr/lib64/libgio-2.0.so.0.4600.2 libgio-2.0.so.0/libgio-2.0.so.0
/bin/cp -afv /usr/lib64/libglib-2.0.so.0.4600.2 libglib-2.0.so.0/libglib-2.0.so.0
/bin/cp -afv /usr/lib64/libgmodule-2.0.so.0.4600.2 libgmodule-2.0.so.0/libgmodule-2.0.so.0
/bin/cp -afv /usr/lib64/libgobject-2.0.so.0.4600.2 libgobject-2.0.so.0/libgobject-2.0.so.0
/bin/cp -afv /usr/lib64/libgthread-2.0.so.0.4600.2 libgthread-2.0.so.0/libgthread-2.0.so.0

nano  `/etc/vmware/bootstrap` an add a line `VMWARE_USE_SHIPPED_LIBS=force`
edit flag offensive delete link more
0

answered 2016-10-11 15:03:58 -0500

I just upgraded to FC23 (from FC22) and had the same issue. The simplest fix is to uninstall vmware and install the latest version from VMWare.

Uninstall vmware: https://pubs.vmware.com/workstation-9...

Get latest version (Workstation Player 12.5): https://www.vmware.com/products/playe...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-14 11:32:47 -0500

Seen: 5,144 times

Last updated: Oct 11 '16