Ask Your Question
0

Dual Boot windows 8.1 and fedora 21

asked 2016-03-17 11:19:37 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Hi

Booting Fedora works fine but if I choose the Windows bootmanager, I get the following error message:

error: disk ''hd0,gpt2 ' not found
error: you need to load the kernel first

My fdisk -l is fdisk -l

Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 3D97FBAA-FE5E-11E3-9094-60029230B016

Device         Start       End   Sectors   Size Type
/dev/sda1       2048    616447    614400   300M Windows recovery environment
/dev/sda2     616448    821247    204800   100M EFI System
/dev/sda3     821248   1083391    262144   128M Microsoft reserved
/dev/sda4    1083392 178053119 176969728  84.4G Microsoft basic data
/dev/sda5  178053120 382853119 204800000  97.7G Microsoft basic data
/dev/sda6  382853120 383877119   1024000   500M Linux filesystem
/dev/sda7  383877120 752639999 368762880 175.9G Linux filesystem
/dev/sda8  752640000 771006463  18366464   8.8G Linux swap
/dev/sda9  771006464 976736255 205729792  98.1G Linux filesystem

And lsblk command output is

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 465.8G  0 disk 
├─sda1   8:1    0   300M  0 part 
├─sda2   8:2    0   100M  0 part /boot/efi
├─sda3   8:3    0   128M  0 part 
├─sda4   8:4    0  84.4G  0 part 
├─sda5   8:5    0  97.7G  0 part 
├─sda6   8:6    0   500M  0 part /boot
├─sda7   8:7    0 175.9G  0 part /home
├─sda8   8:8    0   8.8G  0 part [SWAP]
└─sda9   8:9    0  98.1G  0 part /
sr0     11:0    1  1024M  0 rom
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2016-03-17 13:44:41 -0500

hhlp gravatar image

updated 2016-03-17 13:45:34 -0500

Is this as simple as:

sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

grub2-mkconfig will set the menuentries correctly. root and prefix are set by grub2-efi.cfg automatically.

more info :

Regards.,

edit flag offensive delete link more

Comments

Seems simple. It works

RealPlayerCraft gravatar imageRealPlayerCraft ( 2016-03-17 14:49:47 -0500 )edit

Generating grub configuration file ... Found linux image: /boot/vmlinuz-3.19.5-200.fc21.x86_64 Found initrd image: /boot/initramfs-3.19.5-200.fc21.x86_64.img Found linux image: /boot/vmlinuz-3.17.4-301.fc21.x86_64 Found initrd image: /boot/initramfs-3.17.4-301.fc21.x86_64.img Found linux image: /boot/vmlinuz-0-rescue-3d05e769ddf0454cb1140b44900bb0d6 Found initrd image: /boot/initramfs-0-rescue-3d05e769ddf0454cb1140b44900bb0d6.img done

aswinsatish gravatar imageaswinsatish ( 2016-03-17 23:15:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-17 11:19:37 -0500

Seen: 56 times

Last updated: Mar 17 '16