Ask Your Question
1

Fedora23: slow performance with Wayland

asked 2016-03-22 12:58:35 -0600

whitepeony gravatar image

Description

This issue is present on the login screen or when logged in with Wayland. GNOME without Wayland works fine.

Mouse/keyboard input and graphical output (e.g. animations) freeze at consistent intervals. I get a few seconds of responsiveness followed by a period of waiting.

As long as I do not move the mouse or interact with the interface, I can type into the password field without experiencing any lag whatsoever. This lack of lag does not carry over to other text fields, though, including the terminal, GNOME search, and gedit (when logged in with Wayland).

Specifications

Fresh install of Fedora23. System last updated 22 March 2016

  • Memory: 31.4 GiB
  • CPU: Intel® Core™ i7-6700K @ 4.00GHz × 8
  • GPU: NVIDIA GTX GeForce 980
  • OS Type: 64-bit
  • Graphics: Gallium 0.4 on llvmpipe (LLVM 3.7, 256 bits)
  • GNOME: Version 3.18.2
edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
2

answered 2016-03-22 13:46:39 -0600

hhlp gravatar image

updated 2016-03-22 13:51:48 -0600

@whitepeony thanx for report altought I suggest you to open a bug in bugzilla.redhat against wayland packages, but I just say a few things to you, first - wayland is under hard development, second - I know we can use wayland in Fedora 23 but error happen an the developer team are working very hard to correct this issues, third - primary was a decision to implement it as default sesion in fedora 24 but some things changes sometimes, more info here, Wayland-Not-For-Fedora-24

edit flag offensive delete link more

Comments

Is there a way to disable Wayland on the login screen?

whitepeony gravatar imagewhitepeony ( 2016-03-23 17:54:00 -0600 )edit
1

No, just select gnome as default login screen...or edit cat /etc/gdm/custom.conf

hhlp gravatar imagehhlp ( 2016-03-24 05:08:13 -0600 )edit
1

answered 2016-03-23 15:28:28 -0600

genodeftest gravatar image

I guess your graphics driver isn't ready for Wayland so Wayland needs to do all the rendering on your CPU instead of your GPU, which tends to be slower.

The mouse input lag is known: https://bugzilla.redhat.com/show_bug....

As @hhlp stated: Wayland isn't ready yet.

edit flag offensive delete link more

Comments

His CPU seems capable of anything

wesleyotugo gravatar imagewesleyotugo ( 2016-03-24 02:10:13 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-03-22 12:58:35 -0600

Seen: 2,332 times

Last updated: Mar 23 '16